summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/reg/reg-0.15.5.ebuild')
-rw-r--r--app-emulation/reg/reg-0.15.5.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/app-emulation/reg/reg-0.15.5.ebuild b/app-emulation/reg/reg-0.15.5.ebuild
deleted file mode 100644
index 1691054568ec..000000000000
--- a/app-emulation/reg/reg-0.15.5.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit golang-build golang-vcs-snapshot user
-
-EGO_PN="github.com/genuinetools/reg"
-GIT_COMMIT="1328dc17a08200e8535f7f7098996a7f6c261a3a"
-ARCHIVE_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64"
-
-DESCRIPTION="Docker registry v2 command line client"
-HOMEPAGE="https://github.com/genuinetools/reg"
-SRC_URI="${ARCHIVE_URI}"
-LICENSE="MIT"
-SLOT="0"
-IUSE=""
-
-RESTRICT="test"
-
-pkg_setup() {
- enewgroup reg
- enewuser reg -1 -1 /var/lib/reg reg
-}
-
-src_prepare() {
- pushd src/${EGO_PN} || die
- default
- popd || die
-}
-
-src_compile() {
- pushd src/${EGO_PN} || die
- GOPATH="${S}" go build -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/reg . || die
- popd || die
-}
-
-src_install() {
- dobin bin/*
- dodoc src/${EGO_PN}/README.md
- insinto /var/lib/${PN}
- doins -r src/${EGO_PN}/server/*
- newinitd "${FILESDIR}"/reg.initd reg
- newconfd "${FILESDIR}"/reg.confd reg
-
- keepdir /var/log/reg
- fowners -R reg:reg /var/log/reg /var/lib/reg/static
-}