summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/runc/runc-1.0.0_rc2_p20170222.ebuild')
-rw-r--r--app-emulation/runc/runc-1.0.0_rc2_p20170222.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/app-emulation/runc/runc-1.0.0_rc2_p20170222.ebuild b/app-emulation/runc/runc-1.0.0_rc2_p20170222.ebuild
deleted file mode 100644
index 50ad9ca1ac32..000000000000
--- a/app-emulation/runc/runc-1.0.0_rc2_p20170222.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-EGO_PN="github.com/opencontainers/${PN}"
-
-if [[ ${PV} == *9999 ]]; then
- inherit golang-vcs
-else
- MY_PV="${PV/_/-}"
- EGIT_COMMIT="bd2f9c52cd3b766d993924ae6eba72b82998f3bd"
- RUNC_COMMIT="bd2f9c" # Change this when you update the ebuild
- SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~ppc64"
- inherit golang-vcs-snapshot
-fi
-
-DESCRIPTION="runc container cli tools"
-HOMEPAGE="http://runc.io"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="apparmor hardened +seccomp"
-
-RDEPEND="
- apparmor? ( sys-libs/libapparmor )
- seccomp? ( sys-libs/libseccomp )
- !app-emulation/docker-runc
-"
-
-S=${WORKDIR}/${P}/src/${EGO_PN}
-
-src_compile() {
- # Taken from app-emulation/docker-1.7.0-r1
- export CGO_CFLAGS="-I${ROOT}/usr/include"
- export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')
- -L${ROOT}/usr/$(get_libdir)"
-
- # Setup GOPATH so things build
- rm -rf .gopath
- mkdir -p .gopath/src/"$(dirname "${GITHUB_URI}")"
- ln -sf ../../../.. .gopath/src/"${GITHUB_URI}"
- export GOPATH="${PWD}/.gopath:${PWD}/vendor"
-
- # build up optional flags
- local options=(
- $(usex apparmor 'apparmor')
- $(usex seccomp 'seccomp')
- )
-
- emake BUILDTAGS="${options[*]}" \
- COMMIT="${RUNC_COMMIT}"
-}
-
-src_install() {
- dobin runc
-}