summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/sen/sen-0.6.0.ebuild')
-rw-r--r--app-emulation/sen/sen-0.6.0.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/app-emulation/sen/sen-0.6.0.ebuild b/app-emulation/sen/sen-0.6.0.ebuild
deleted file mode 100644
index d8c239c34073..000000000000
--- a/app-emulation/sen/sen-0.6.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Terminal User Interface for docker engine"
-HOMEPAGE="https://github.com/TomasTomecek/sen"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-
-RDEPEND="dev-python/urwid[${PYTHON_USEDEP}]
- dev-python/urwidtrees[${PYTHON_USEDEP}]
- dev-python/docker-py[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/flexmock[${PYTHON_USEDEP}]
- )
- "
-
-python_install_all() {
- distutils-r1_python_install_all
- dodoc -r docs
-}
-
-python_test() {
- pytest -vv tests || die "pytest failed"
-}