summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/spice-protocol/spice-protocol-9999.ebuild')
-rw-r--r--app-emulation/spice-protocol/spice-protocol-9999.ebuild23
1 files changed, 7 insertions, 16 deletions
diff --git a/app-emulation/spice-protocol/spice-protocol-9999.ebuild b/app-emulation/spice-protocol/spice-protocol-9999.ebuild
index 781224a6a4c7..8908284a7192 100644
--- a/app-emulation/spice-protocol/spice-protocol-9999.ebuild
+++ b/app-emulation/spice-protocol/spice-protocol-9999.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+inherit meson
if [[ ${PV} = *9999* ]]; then
- inherit git-r3 autotools
+ inherit git-r3
EGIT_REPO_URI="https://anongit.freedesktop.org/git/spice/spice-protocol.git"
- SRC_URI=""
- KEYWORDS=""
else
- SRC_URI="https://www.spice-space.org/download/releases/${P}.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+ SRC_URI="https://www.spice-space.org/download/releases/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
DESCRIPTION="Headers defining the SPICE protocol"
@@ -18,12 +18,3 @@ HOMEPAGE="https://spice-space.org/"
LICENSE="BSD"
SLOT="0"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- [[ ${PV} = *9999* ]] && eautoreconf
- default
-}