summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/containerd/containerd-0.2.4.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/app-emulation/containerd/containerd-0.2.4.ebuild b/app-emulation/containerd/containerd-0.2.4.ebuild
index 8c9e5d9b86a2..2fce33a3eb66 100644
--- a/app-emulation/containerd/containerd-0.2.4.ebuild
+++ b/app-emulation/containerd/containerd-0.2.4.ebuild
@@ -20,7 +20,7 @@ HOMEPAGE="https://containerd.tools"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="+seccomp"
+IUSE="hardened +seccomp"
DEPEND=""
RDEPEND=">=app-emulation/runc-1.0.0_rc2
@@ -31,7 +31,8 @@ S=${WORKDIR}/${P}/src/${EGO_PN}
src_compile() {
local options=( $(usex seccomp "seccomp") )
export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
- LDFLAGS= emake GIT_COMMIT="$EGIT_COMMIT" BUILDTAGS="${options[@]}"
+ LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') \
+ emake GIT_COMMIT="$EGIT_COMMIT" BUILDTAGS="${options[@]}"
}
src_install() {