summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-eselect/eselect-java/eselect-java-0.5.0.ebuild')
-rw-r--r--app-eselect/eselect-java/eselect-java-0.5.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-eselect/eselect-java/eselect-java-0.5.0.ebuild b/app-eselect/eselect-java/eselect-java-0.5.0.ebuild
new file mode 100644
index 000000000000..36d7a77f06f5
--- /dev/null
+++ b/app-eselect/eselect-java/eselect-java-0.5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A set of eselect modules for Java"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Java"
+SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ppc64 ~riscv x86 ~amd64-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="app-admin/eselect"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+pkg_postinst() {
+ local REMOVED=0
+
+ rm -v "${EROOT}"/usr/lib*/nsbrowser/plugins/javaplugin.so 2>/dev/null && REMOVED=1
+ rm -v "${EROOT}"/etc/java-config-2/current-icedtea-web-vm 2>/dev/null && REMOVED=1
+
+ if [[ ${REMOVED} = 1 ]]; then
+ elog "The eselect java-nsplugin module has been removed and your configuration"
+ elog "has been cleaned up. From now on, you may only install either Oracle or"
+ elog "IcedTea's plugin but not both. Note you can use IcedTea's plugin with an"
+ elog "Oracle VM. See the README installed with icedtea-web for more details."
+ fi
+}