summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-eselect/eselect-php/eselect-php-9999.ebuild')
-rw-r--r--app-eselect/eselect-php/eselect-php-9999.ebuild25
1 files changed, 10 insertions, 15 deletions
diff --git a/app-eselect/eselect-php/eselect-php-9999.ebuild b/app-eselect/eselect-php/eselect-php-9999.ebuild
index e6b5ef3d8804..d43863a6ded3 100644
--- a/app-eselect/eselect-php/eselect-php-9999.ebuild
+++ b/app-eselect/eselect-php/eselect-php-9999.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit systemd git-r3 autotools
+TMPFILES_OPTIONAL="yes"
+inherit autotools git-r3 tmpfiles
DESCRIPTION="PHP eselect module"
HOMEPAGE="https://gitweb.gentoo.org/proj/eselect-php.git/"
@@ -16,14 +17,15 @@ IUSE="fpm apache2"
# The "DirectoryIndex" line in 70_mod_php.conf requires mod_dir.
RDEPEND="app-admin/eselect
- apache2? ( www-servers/apache[apache2_modules_dir] )"
+ apache2? ( www-servers/apache[apache2_modules_dir] )
+ fpm? ( virtual/tmpfiles )"
src_prepare() {
- eapply_user
+ default
eautoreconf
}
-src_configure(){
+src_configure() {
# We expect localstatedir to be "var"ish, not "var/lib"ish, because
# that's what PHP upstream expects. See for example the FPM
# configuration where they put logs in @localstatedir@/log.
@@ -37,13 +39,6 @@ src_configure(){
$(use_enable fpm)
}
-src_install() {
- default
-
- if use fpm ; then
- systemd_dotmpfilesd "${FILESDIR}/php-fpm.conf"
- sed -e "s,@libdir@,$(get_libdir),g" "${FILESDIR}/php-fpm-launcher-r3" > "${T}"/php-fpm-launcher || die
- exeinto /usr/libexec
- doexe "${T}"/php-fpm-launcher
- fi
+pkg_postinst() {
+ use fpm && tmpfiles_process php-fpm.conf
}