summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-eselect/eselect-pinentry')
-rw-r--r--app-eselect/eselect-pinentry/eselect-pinentry-0.7.3.ebuild19
-rw-r--r--app-eselect/eselect-pinentry/eselect-pinentry-0.7.4.ebuild19
-rw-r--r--app-eselect/eselect-pinentry/eselect-pinentry-0.7.ebuild23
-rw-r--r--app-eselect/eselect-pinentry/files/pinentry.eselect-0.7.3 (renamed from app-eselect/eselect-pinentry/files/pinentry.eselect-0.7)15
-rw-r--r--app-eselect/eselect-pinentry/files/pinentry.eselect-0.7.420
-rw-r--r--app-eselect/eselect-pinentry/metadata.xml8
6 files changed, 72 insertions, 32 deletions
diff --git a/app-eselect/eselect-pinentry/eselect-pinentry-0.7.3.ebuild b/app-eselect/eselect-pinentry/eselect-pinentry-0.7.3.ebuild
new file mode 100644
index 000000000000..3d65df2747d5
--- /dev/null
+++ b/app-eselect/eselect-pinentry/eselect-pinentry-0.7.3.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Manage /usr/bin/pinentry symlink"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Eselect"
+S="${WORKDIR}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND=">=app-eselect/eselect-lib-bin-symlink-0.1.1"
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ newins "${FILESDIR}"/pinentry.eselect-${PV} pinentry.eselect
+}
diff --git a/app-eselect/eselect-pinentry/eselect-pinentry-0.7.4.ebuild b/app-eselect/eselect-pinentry/eselect-pinentry-0.7.4.ebuild
new file mode 100644
index 000000000000..2f34f9567def
--- /dev/null
+++ b/app-eselect/eselect-pinentry/eselect-pinentry-0.7.4.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Manage /usr/bin/pinentry symlink"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Eselect"
+S="${WORKDIR}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND=">=app-eselect/eselect-lib-bin-symlink-0.1.1"
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ newins "${FILESDIR}"/pinentry.eselect-${PV} pinentry.eselect
+}
diff --git a/app-eselect/eselect-pinentry/eselect-pinentry-0.7.ebuild b/app-eselect/eselect-pinentry/eselect-pinentry-0.7.ebuild
deleted file mode 100644
index 259f89e9bf28..000000000000
--- a/app-eselect/eselect-pinentry/eselect-pinentry-0.7.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="Manage /usr/bin/pinentry symlink"
-HOMEPAGE="https://www.gentoo.org/proj/en/eselect/"
-SRC_URI=""
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RDEPEND=">=app-eselect/eselect-lib-bin-symlink-0.1.1"
-
-S="${FILESDIR}"
-
-src_install() {
- default
- insinto /usr/share/eselect/modules
- newins pinentry.eselect-${PV} pinentry.eselect
-}
diff --git a/app-eselect/eselect-pinentry/files/pinentry.eselect-0.7 b/app-eselect/eselect-pinentry/files/pinentry.eselect-0.7.3
index ec49ca1a602a..bc058bb41ee7 100644
--- a/app-eselect/eselect-pinentry/files/pinentry.eselect-0.7
+++ b/app-eselect/eselect-pinentry/files/pinentry.eselect-0.7.3
@@ -1,12 +1,19 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
DESCRIPTION="Manage /usr/bin/pinentry implementation"
-MAINTAINER="ssuominen@gentoo.org"
-VERSION="0.7"
+MAINTAINER="maintainer-needed@gentoo.org"
+VERSION="0.7.3"
SYMLINK_PATH=/usr/bin/pinentry
-SYMLINK_TARGETS=( pinentry-gnome3 pinentry-qt pinentry-gtk-2 pinentry-qt4 pinentry-curses pinentry-tty )
+SYMLINK_TARGETS=(
+ pinentry-efl
+ pinentry-gnome3
+ pinentry-qt5
+ pinentry-curses
+ pinentry-tty
+ pinentry-emacs
+)
SYMLINK_DESCRIPTION='pinentry binary'
inherit bin-symlink
diff --git a/app-eselect/eselect-pinentry/files/pinentry.eselect-0.7.4 b/app-eselect/eselect-pinentry/files/pinentry.eselect-0.7.4
new file mode 100644
index 000000000000..74c6f14d8b53
--- /dev/null
+++ b/app-eselect/eselect-pinentry/files/pinentry.eselect-0.7.4
@@ -0,0 +1,20 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="Manage /usr/bin/pinentry implementation"
+MAINTAINER="maintainer-needed@gentoo.org"
+VERSION="0.7.4"
+
+SYMLINK_PATH=/usr/bin/pinentry
+SYMLINK_TARGETS=(
+ pinentry-efl
+ pinentry-gnome3
+ pinentry-qt5
+ pinentry-qt6
+ pinentry-curses
+ pinentry-tty
+ pinentry-emacs
+)
+SYMLINK_DESCRIPTION='pinentry binary'
+
+inherit bin-symlink
diff --git a/app-eselect/eselect-pinentry/metadata.xml b/app-eselect/eselect-pinentry/metadata.xml
index 6698a4ab7883..c3bda71eefca 100644
--- a/app-eselect/eselect-pinentry/metadata.xml
+++ b/app-eselect/eselect-pinentry/metadata.xml
@@ -1,8 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>zlogene@gentoo.org</email>
- <name>Mikle Kolyada</name>
- </maintainer>
+ <!-- maintainer-needed -->
+ <stabilize-allarches/>
</pkgmetadata>