summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-eselect/eselect-postgresql/eselect-postgresql-2.4-r1.ebuild')
-rw-r--r--app-eselect/eselect-postgresql/eselect-postgresql-2.4-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-eselect/eselect-postgresql/eselect-postgresql-2.4-r1.ebuild b/app-eselect/eselect-postgresql/eselect-postgresql-2.4-r1.ebuild
new file mode 100644
index 000000000000..6953c89741ad
--- /dev/null
+++ b/app-eselect/eselect-postgresql/eselect-postgresql-2.4-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Utility to select the default PostgreSQL slot"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="https://dev.gentoo.org/~titanofold/${P}.tbz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="app-admin/eselect"
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ doins postgresql.eselect
+
+ dosym eselect /usr/bin/postgresql-config
+}
+
+pkg_postinst() {
+ postgresql-config update
+}