summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-eselect/eselect-python/eselect-python-20160516.ebuild')
-rw-r--r--app-eselect/eselect-python/eselect-python-20160516.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/app-eselect/eselect-python/eselect-python-20160516.ebuild b/app-eselect/eselect-python/eselect-python-20160516.ebuild
deleted file mode 100644
index f52c5f8bf86b..000000000000
--- a/app-eselect/eselect-python/eselect-python-20160516.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-if [[ ${PV} == "99999999" ]] ; then
- inherit autotools git-r3
- EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
-else
- SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.bz2"
- KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-DESCRIPTION="Eselect module for management of multiple Python versions"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Python"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE=""
-
-# python-exec-2.4.2 for working -l option
-RDEPEND=">=app-admin/eselect-1.2.3
- >=dev-lang/python-exec-2.4.2"
-
-src_prepare() {
- [[ ${PV} == "99999999" ]] && eautoreconf
-}
-
-pkg_postinst() {
- local py
-
- if has_version 'dev-lang/python'; then
- eselect python update --if-unset
- fi
-
- if has_version "=dev-lang/python-3*"; then
- eselect python update "--python3" --if-unset
- fi
-}