summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-eselect/eselect-python')
-rw-r--r--app-eselect/eselect-python/Manifest4
-rw-r--r--app-eselect/eselect-python/eselect-python-20111108.ebuild56
-rw-r--r--app-eselect/eselect-python/eselect-python-20131210.ebuild53
-rw-r--r--app-eselect/eselect-python/eselect-python-20140115.ebuild51
-rw-r--r--app-eselect/eselect-python/eselect-python-20140125.ebuild51
-rw-r--r--app-eselect/eselect-python/eselect-python-99999999.ebuild51
-rw-r--r--app-eselect/eselect-python/metadata.xml5
7 files changed, 271 insertions, 0 deletions
diff --git a/app-eselect/eselect-python/Manifest b/app-eselect/eselect-python/Manifest
new file mode 100644
index 000000000000..98a02a21b9f6
--- /dev/null
+++ b/app-eselect/eselect-python/Manifest
@@ -0,0 +1,4 @@
+DIST eselect-python-20111108.tar.bz2 64959 SHA256 34d7618808a3c1d22e6763bc6c67d5ae47a1fa371f5e91de95a911da9aceba5e SHA512 59a493128753ae968c6fa30eb870f52198de7bb5090213ef0b8c0d3d8b1f552ac514174dd1e97e54dd9434432be1a68ad01853d1ffb21e53d28d08f623199dac WHIRLPOOL 605730de7fee70cf5a33e15c8e16a938807c5ed32f80ff0435a196f03cb38ce397092626c88df598b1b88dab7ee3b8c7f3105b9f3b88acb13fe532f964b8aced
+DIST eselect-python-20131210.tar.bz2 71802 SHA256 61ff5a5a3ae7982c6ffd503886cbcd35142df05f07008722b90ab5036e4bf8f2 SHA512 8c523019e2a8fe7f1679b96a3da22326dbe65888739bb8cce3c4e2aa7c2c08cada01196a65c8fe35e08b3b7682a3f695e453e9ef1fb53f6b8886c51c09107d60 WHIRLPOOL e8c75eb1ad6fcaaba50cae9d10d2414b29b3cfc8d06c79257948b0d0b4e7c2156d1672be4f5edd28055b5ae3f6aa54b1b8ef6eaaae9dfa1ce9b7b0b68dbc712a
+DIST eselect-python-20140115.tar.bz2 71910 SHA256 5898ee19015ae905168e8b7aa76552b96f691285ab77c426b6a9238ecf742e45 SHA512 65d6a6b9dfa0a0f4bea5352f965bed8942a16382135edea093342fa79a824d114b900cbcf607490f260b4ce4e5a2eb57872169e5494f8e6e65f41dd63cd5d335 WHIRLPOOL 633bca3e8a87e04c54a3790bb207da92d41af604cce7f8600c5317f6a759c55efbd3e5ba658e893d2d079248d2dadb1a0bb60248960e3d20cd766768a228d8c5
+DIST eselect-python-20140125.tar.bz2 72102 SHA256 ee7b470f7facc42285bab7f4b947280741515a85c9067339511c219248f8fdfb SHA512 94d4eb5a1af365c6f56a6fc2b75298018267cd4f6004f30b2e4d0c4744d3e82b33f6c82e6f0ea0f15132d5157c3ace99fa167bbf3ebada46edd2e005ca96eb51 WHIRLPOOL 70d5f9af2929507d26e56080ce934066d2de5f16030dfd63b016215465ad5fc89eb952d64cc545c7058d146108e26925741d2c8fbaba08abba1a5cae7b0c23b6
diff --git a/app-eselect/eselect-python/eselect-python-20111108.ebuild b/app-eselect/eselect-python/eselect-python-20111108.ebuild
new file mode 100644
index 000000000000..e64a2bd4a7bf
--- /dev/null
+++ b/app-eselect/eselect-python/eselect-python-20111108.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# Keep the EAPI low here because everything else depends on it.
+# We want to make upgrading simpler.
+
+ESVN_PROJECT="eselect-python"
+ESVN_REPO_URI="https://overlays.gentoo.org/svn/proj/python/projects/eselect-python/trunk"
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit autotools subversion
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2"
+ KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+fi
+
+DESCRIPTION="Eselect module for management of multiple Python versions"
+HOMEPAGE="http://www.gentoo.org/proj/en/Python/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=app-admin/eselect-1.2.3"
+# Avoid autotool deps for released versions for circ dep issues.
+if [[ ${PV} == "99999999" ]] ; then
+ DEPEND="sys-devel/autoconf"
+else
+ DEPEND=""
+fi
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ [[ -x configure ]] || eautoreconf
+}
+
+src_install() {
+ keepdir /etc/env.d/python
+ emake DESTDIR="${D}" install || die
+}
+
+pkg_preinst() {
+ if has_version "<${CATEGORY}/${PN}-20090804" || ! has_version "${CATEGORY}/${PN}"; then
+ run_eselect_python_update="1"
+ fi
+}
+
+pkg_postinst() {
+ if [[ "${run_eselect_python_update}" == "1" ]]; then
+ ebegin "Running \`eselect python update\`"
+ eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2 > /dev/null
+ eend "$?"
+ fi
+}
diff --git a/app-eselect/eselect-python/eselect-python-20131210.ebuild b/app-eselect/eselect-python/eselect-python-20131210.ebuild
new file mode 100644
index 000000000000..7f1fd0c92075
--- /dev/null
+++ b/app-eselect/eselect-python/eselect-python-20131210.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# Keep the EAPI low here because everything else depends on it.
+# We want to make upgrading simpler.
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~floppym/dist/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+fi
+
+DESCRIPTION="Eselect module for management of multiple Python versions"
+HOMEPAGE="http://www.gentoo.org/proj/en/Python/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=app-admin/eselect-1.2.3"
+# Avoid autotool deps for released versions for circ dep issues.
+if [[ ${PV} == "99999999" ]] ; then
+ DEPEND="sys-devel/autoconf"
+else
+ DEPEND=""
+fi
+
+src_unpack() {
+ if [[ ${PV} == "99999999" ]] ; then
+ git-r3_src_unpack
+ cd "${S}"
+ eautoreconf
+ else
+ unpack ${A}
+ fi
+}
+
+src_install() {
+ keepdir /etc/env.d/python
+ emake DESTDIR="${D}" install || die
+}
+
+pkg_postinst() {
+ local ret=0
+ ebegin "Running 'eselect python update'"
+ eselect python update --python2 --if-unset || ret=1
+ eselect python update --python3 --if-unset || ret=1
+ eend ${ret}
+}
diff --git a/app-eselect/eselect-python/eselect-python-20140115.ebuild b/app-eselect/eselect-python/eselect-python-20140115.ebuild
new file mode 100644
index 000000000000..bb8f032ca066
--- /dev/null
+++ b/app-eselect/eselect-python/eselect-python-20140115.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# Keep the EAPI low here because everything else depends on it.
+# We want to make upgrading simpler.
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~floppym/dist/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+fi
+
+DESCRIPTION="Eselect module for management of multiple Python versions"
+HOMEPAGE="http://www.gentoo.org/proj/en/Python/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=app-admin/eselect-1.2.3"
+
+src_unpack() {
+ if [[ ${PV} == "99999999" ]] ; then
+ git-r3_src_unpack
+ cd "${S}"
+ eautoreconf
+ else
+ unpack ${A}
+ fi
+}
+
+src_install() {
+ keepdir /etc/env.d/python
+ emake DESTDIR="${D}" install || die
+}
+
+pkg_postinst() {
+ if has_version 'dev-lang/python'; then
+ eselect python update --if-unset
+ fi
+ if has_version '=dev-lang/python-2*'; then
+ eselect python update --python2 --if-unset
+ fi
+ if has_version '=dev-lang/python-3*'; then
+ eselect python update --python3 --if-unset
+ fi
+}
diff --git a/app-eselect/eselect-python/eselect-python-20140125.ebuild b/app-eselect/eselect-python/eselect-python-20140125.ebuild
new file mode 100644
index 000000000000..d9c34b9d9aa3
--- /dev/null
+++ b/app-eselect/eselect-python/eselect-python-20140125.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# Keep the EAPI low here because everything else depends on it.
+# We want to make upgrading simpler.
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~floppym/dist/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-aix ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Eselect module for management of multiple Python versions"
+HOMEPAGE="http://www.gentoo.org/proj/en/Python/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=app-admin/eselect-1.2.3"
+
+src_unpack() {
+ if [[ ${PV} == "99999999" ]] ; then
+ git-r3_src_unpack
+ cd "${S}"
+ eautoreconf
+ else
+ unpack ${A}
+ fi
+}
+
+src_install() {
+ keepdir /etc/env.d/python
+ emake DESTDIR="${D}" install || die
+}
+
+pkg_postinst() {
+ if has_version 'dev-lang/python'; then
+ eselect python update --if-unset
+ fi
+ if has_version '=dev-lang/python-2*'; then
+ eselect python update --python2 --if-unset
+ fi
+ if has_version '=dev-lang/python-3*'; then
+ eselect python update --python3 --if-unset
+ fi
+}
diff --git a/app-eselect/eselect-python/eselect-python-99999999.ebuild b/app-eselect/eselect-python/eselect-python-99999999.ebuild
new file mode 100644
index 000000000000..d9c34b9d9aa3
--- /dev/null
+++ b/app-eselect/eselect-python/eselect-python-99999999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# Keep the EAPI low here because everything else depends on it.
+# We want to make upgrading simpler.
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~floppym/dist/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-aix ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Eselect module for management of multiple Python versions"
+HOMEPAGE="http://www.gentoo.org/proj/en/Python/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=app-admin/eselect-1.2.3"
+
+src_unpack() {
+ if [[ ${PV} == "99999999" ]] ; then
+ git-r3_src_unpack
+ cd "${S}"
+ eautoreconf
+ else
+ unpack ${A}
+ fi
+}
+
+src_install() {
+ keepdir /etc/env.d/python
+ emake DESTDIR="${D}" install || die
+}
+
+pkg_postinst() {
+ if has_version 'dev-lang/python'; then
+ eselect python update --if-unset
+ fi
+ if has_version '=dev-lang/python-2*'; then
+ eselect python update --python2 --if-unset
+ fi
+ if has_version '=dev-lang/python-3*'; then
+ eselect python update --python3 --if-unset
+ fi
+}
diff --git a/app-eselect/eselect-python/metadata.xml b/app-eselect/eselect-python/metadata.xml
new file mode 100644
index 000000000000..301d2207cc29
--- /dev/null
+++ b/app-eselect/eselect-python/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>