summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-forensics/aide')
-rw-r--r--app-forensics/aide/Manifest4
-rw-r--r--app-forensics/aide/aide-0.17.4-r4.ebuild (renamed from app-forensics/aide/aide-0.17.4-r2.ebuild)20
-rw-r--r--app-forensics/aide/aide-0.18.2.ebuild108
-rw-r--r--app-forensics/aide/aide-0.18.3.ebuild106
-rw-r--r--app-forensics/aide/aide-0.18.4.ebuild106
-rw-r--r--app-forensics/aide/aide-0.18.ebuild108
-rw-r--r--app-forensics/aide/files/aide-0.17.4-bashism.patch60
-rw-r--r--app-forensics/aide/files/aide-0.17.4-configure.patch131
8 files changed, 575 insertions, 68 deletions
diff --git a/app-forensics/aide/Manifest b/app-forensics/aide/Manifest
index a2aadd38e2c3..50d4b98fc6ec 100644
--- a/app-forensics/aide/Manifest
+++ b/app-forensics/aide/Manifest
@@ -1 +1,5 @@
DIST aide-0.17.4.tar.gz 331783 BLAKE2B 584a385d0a0e80edf0b89eef202431adfea7fe8ba04c774e49dfb7230e766e19a48572e9d6c80386668572e459db9770b04978df484bd49c7de6433657500e13 SHA512 b6dba54fd204e1899d47b0b4139786cbeaa51c388027e2cfc1bb839297a70ae8ad6f37429594a730fac8007d62b4ba5b61a4aa22edbc55cbe986ccfaf5197f31
+DIST aide-0.18.2.tar.gz 382582 BLAKE2B 267233a4dfdbc5a433389c20a1abe753133dfa01ecc205769c89a9b4699535b1d00e9df6527ae8298f4cb920e2f755e4d75d17b4a2449041a85c8c5e5ecc2abc SHA512 3a209db9dc1adb345494ce20a5c3def9f40ae49723d3a978d8e9b38f43239496a330b484ed93adba88154770ce1f1a0f3cdeb2ff8d991d28a1d66cfa6cd9b68b
+DIST aide-0.18.3.tar.gz 382694 BLAKE2B f5e79d80c1fa2ba15096d38c1a1d197fc8665bc0ff03665367abce7722561f2054cc64f51429a1411d6aaa0df315869ac99314e660acdff31bf1dc6b471a62b8 SHA512 22f1d2d3e14fa88639587f5a61e114b89c784a87f636c1bbb245e620254b60ec07692e51ae27386a84810d7a915e0ddf5c5073fecb6eb72148ff5035ef8525eb
+DIST aide-0.18.4.tar.gz 382874 BLAKE2B e8fe8a115236f055f24b907ddcf540f02658b85c1df99ff9a8f58dfa9489de3d542b25bb947e047c8363c81d1f0ad0730fd77efacabe15fa24bbafc3fd807687 SHA512 31a17fc97ed9bda5dc4a492bcee699442cee1ea3829b1b06cf91ef9234a8b033677c281979902cbc6a8db0269c7f00499897940df07beff14cbb88b8fe6390f5
+DIST aide-0.18.tar.gz 375922 BLAKE2B 03c961682fd25581831ca0715e57546b5595057115a456778ac0846fd1f23622600a061e2d8524f7381dfa6d43cefcdaa52d00eed2639dd60c7f3501efe8b474 SHA512 99d8140523ebe1d80b5d73c20bf13b8559aa22f08a9df485c15daeba7f5448c27d86ed310f2e7963076958dbe1fc2e4636807ca073dd0a6568b4eb8af2a38f4b
diff --git a/app-forensics/aide/aide-0.17.4-r2.ebuild b/app-forensics/aide/aide-0.17.4-r4.ebuild
index eee74dece344..71aa7366350b 100644
--- a/app-forensics/aide/aide-0.17.4-r2.ebuild
+++ b/app-forensics/aide/aide-0.17.4-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,9 +12,10 @@ SRC_URI="https://github.com/aide/aide/releases/download/v${PV}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm64 x86"
-IUSE="acl audit curl e2fs mhash selinux xattr zlib"
+IUSE="acl audit curl e2fs mhash selinux xattr"
DEPEND="dev-libs/libpcre
+ sys-libs/zlib
acl? ( virtual/acl )
audit? ( sys-process/audit )
curl? ( net-misc/curl )
@@ -25,12 +26,11 @@ DEPEND="dev-libs/libpcre
)
mhash? ( app-crypt/mhash )
selinux? ( sys-libs/libselinux )
- xattr? ( sys-apps/attr )
- zlib? ( sys-libs/zlib )"
+ xattr? ( sys-apps/attr )"
RDEPEND="${DEPEND}
selinux? ( sec-policy/selinux-aide )"
-BDEPEND="sys-devel/bison
- sys-devel/flex
+BDEPEND="app-alternatives/yacc
+ app-alternatives/lex
virtual/pkgconfig"
DISABLE_AUTOFORMATTING=1
@@ -44,7 +44,7 @@ management easier. Please run 'aideinit --help' for more information."
PATCHES=(
"${FILESDIR}"/${PN}-0.16-fix-acl-configure-option.patch
- "${FILESDIR}"/${PN}-0.17.4-bashism.patch
+ "${FILESDIR}"/${PN}-0.17.4-configure.patch
)
src_prepare() {
@@ -65,12 +65,16 @@ src_configure() {
local myeconfargs=(
--sysconfdir="${EPREFIX}"/etc/${PN}
+ # Needed even in EAPI=8, >=portage-3.0.40 skips it here (bug #887177)
+ --disable-static
+
# Disable broken l10n support: https://sourceforge.net/p/aide/bugs/98/
# This doesn't affect anything because there are no localizations yet.
--without-locale
--without-prelink
- $(use_with zlib)
+
+ --with-zlib
$(use_with curl)
$(use_with acl posix-acl)
$(use_with selinux)
diff --git a/app-forensics/aide/aide-0.18.2.ebuild b/app-forensics/aide/aide-0.18.2.ebuild
new file mode 100644
index 000000000000..d444643eab3b
--- /dev/null
+++ b/app-forensics/aide/aide-0.18.2.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="AIDE (Advanced Intrusion Detection Environment) is a file integrity checker"
+HOMEPAGE="https://aide.github.io/ https://github.com/aide/aide"
+SRC_URI="https://github.com/aide/aide/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE="acl audit curl e2fs mhash selinux xattr"
+
+DEPEND="
+ dev-libs/libpcre2
+ sys-libs/zlib
+ acl? ( virtual/acl )
+ audit? ( sys-process/audit )
+ curl? ( net-misc/curl )
+ e2fs? ( sys-fs/e2fsprogs )
+ !mhash? (
+ dev-libs/libgcrypt:=
+ dev-libs/libgpg-error
+ )
+ mhash? ( app-crypt/mhash )
+ selinux? ( sys-libs/libselinux )
+ xattr? ( sys-apps/attr )
+"
+RDEPEND="
+ ${DEPEND}
+ selinux? ( sec-policy/selinux-aide )
+"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+"
+
+DISABLE_AUTOFORMATTING=1
+DOC_CONTENTS="
+Example configuration file was installed at '${EPREFIX}/etc/aide/aide.conf'.
+Please edit it to meet your needs. Refer to aide.conf(5) manual page
+for more information.
+
+A helper script, aideinit, was installed and can be used to make AIDE
+management easier. Please run 'aideinit --help' for more information."
+
+src_prepare() {
+ default
+
+ sed -i -e 's| -Werror||g' configure.ac || die
+
+ # Only needed for snapshots.
+ if [[ ${PV} == *_p* ]] ; then
+ echo "m4_define([AIDE_VERSION], [${PV}])" > version.m4 || die
+ fi
+}
+
+src_configure() {
+ # Needs Bison, flex
+ unset YACC
+ export LEX=flex
+
+ local myeconfargs=(
+ --sysconfdir="${EPREFIX}"/etc/${PN}
+
+ # Needed even in EAPI=8, >=portage-3.0.40 skips it here (bug #887177)
+ --disable-static
+
+ # Disable broken l10n support: https://sourceforge.net/p/aide/bugs/98/
+ # This doesn't affect anything because there are no localizations yet.
+ --without-locale
+
+ --with-zlib
+ $(use_with curl)
+ $(use_with acl posix-acl)
+ $(use_with selinux)
+ $(use_with xattr)
+ $(use_with e2fs e2fsattrs)
+ $(use_with mhash mhash)
+ $(use_with !mhash gcrypt)
+ $(use_with audit)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ readme.gentoo_create_doc
+
+ insinto /etc/${PN}
+ insopts -m0600
+ newins "${FILESDIR}"/aide.conf-r2 aide.conf
+
+ dosbin "${FILESDIR}"/aideinit
+ dodoc -r contrib/ "${FILESDIR}"/aide.cron-r2
+
+ keepdir /var/{lib,log}/${PN}
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/app-forensics/aide/aide-0.18.3.ebuild b/app-forensics/aide/aide-0.18.3.ebuild
new file mode 100644
index 000000000000..d7e4d4b1948d
--- /dev/null
+++ b/app-forensics/aide/aide-0.18.3.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="AIDE (Advanced Intrusion Detection Environment) is a file integrity checker"
+HOMEPAGE="https://aide.github.io/ https://github.com/aide/aide"
+SRC_URI="https://github.com/aide/aide/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE="acl audit curl e2fs mhash selinux xattr"
+
+DEPEND="
+ dev-libs/libpcre2
+ sys-libs/zlib
+ acl? ( virtual/acl )
+ audit? ( sys-process/audit )
+ curl? ( net-misc/curl )
+ e2fs? ( sys-fs/e2fsprogs )
+ !mhash? (
+ dev-libs/libgcrypt:=
+ dev-libs/libgpg-error
+ )
+ mhash? ( app-crypt/mhash )
+ selinux? ( sys-libs/libselinux )
+ xattr? ( sys-apps/attr )
+"
+RDEPEND="
+ ${DEPEND}
+ selinux? ( sec-policy/selinux-aide )
+"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+"
+
+DISABLE_AUTOFORMATTING=1
+DOC_CONTENTS="
+Example configuration file was installed at '${EPREFIX}/etc/aide/aide.conf'.
+Please edit it to meet your needs. Refer to aide.conf(5) manual page
+for more information.
+
+A helper script, aideinit, was installed and can be used to make AIDE
+management easier. Please run 'aideinit --help' for more information."
+
+src_prepare() {
+ default
+
+ # Only needed for snapshots.
+ if [[ ${PV} == *_p* ]] ; then
+ echo "m4_define([AIDE_VERSION], [${PV}])" > version.m4 || die
+ fi
+}
+
+src_configure() {
+ # Needs Bison, flex
+ unset YACC
+ export LEX=flex
+
+ local myeconfargs=(
+ --sysconfdir="${EPREFIX}"/etc/${PN}
+
+ # Needed even in EAPI=8, >=portage-3.0.40 skips it here (bug #887177)
+ --disable-static
+
+ # Disable broken l10n support: https://sourceforge.net/p/aide/bugs/98/
+ # This doesn't affect anything because there are no localizations yet.
+ --without-locale
+
+ --with-zlib
+ $(use_with curl)
+ $(use_with acl posix-acl)
+ $(use_with selinux)
+ $(use_with xattr)
+ $(use_with e2fs e2fsattrs)
+ $(use_with mhash mhash)
+ $(use_with !mhash gcrypt)
+ $(use_with audit)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ readme.gentoo_create_doc
+
+ insinto /etc/${PN}
+ insopts -m0600
+ newins "${FILESDIR}"/aide.conf-r2 aide.conf
+
+ dosbin "${FILESDIR}"/aideinit
+ dodoc -r contrib/ "${FILESDIR}"/aide.cron-r2
+
+ keepdir /var/{lib,log}/${PN}
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/app-forensics/aide/aide-0.18.4.ebuild b/app-forensics/aide/aide-0.18.4.ebuild
new file mode 100644
index 000000000000..d7e4d4b1948d
--- /dev/null
+++ b/app-forensics/aide/aide-0.18.4.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="AIDE (Advanced Intrusion Detection Environment) is a file integrity checker"
+HOMEPAGE="https://aide.github.io/ https://github.com/aide/aide"
+SRC_URI="https://github.com/aide/aide/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE="acl audit curl e2fs mhash selinux xattr"
+
+DEPEND="
+ dev-libs/libpcre2
+ sys-libs/zlib
+ acl? ( virtual/acl )
+ audit? ( sys-process/audit )
+ curl? ( net-misc/curl )
+ e2fs? ( sys-fs/e2fsprogs )
+ !mhash? (
+ dev-libs/libgcrypt:=
+ dev-libs/libgpg-error
+ )
+ mhash? ( app-crypt/mhash )
+ selinux? ( sys-libs/libselinux )
+ xattr? ( sys-apps/attr )
+"
+RDEPEND="
+ ${DEPEND}
+ selinux? ( sec-policy/selinux-aide )
+"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+"
+
+DISABLE_AUTOFORMATTING=1
+DOC_CONTENTS="
+Example configuration file was installed at '${EPREFIX}/etc/aide/aide.conf'.
+Please edit it to meet your needs. Refer to aide.conf(5) manual page
+for more information.
+
+A helper script, aideinit, was installed and can be used to make AIDE
+management easier. Please run 'aideinit --help' for more information."
+
+src_prepare() {
+ default
+
+ # Only needed for snapshots.
+ if [[ ${PV} == *_p* ]] ; then
+ echo "m4_define([AIDE_VERSION], [${PV}])" > version.m4 || die
+ fi
+}
+
+src_configure() {
+ # Needs Bison, flex
+ unset YACC
+ export LEX=flex
+
+ local myeconfargs=(
+ --sysconfdir="${EPREFIX}"/etc/${PN}
+
+ # Needed even in EAPI=8, >=portage-3.0.40 skips it here (bug #887177)
+ --disable-static
+
+ # Disable broken l10n support: https://sourceforge.net/p/aide/bugs/98/
+ # This doesn't affect anything because there are no localizations yet.
+ --without-locale
+
+ --with-zlib
+ $(use_with curl)
+ $(use_with acl posix-acl)
+ $(use_with selinux)
+ $(use_with xattr)
+ $(use_with e2fs e2fsattrs)
+ $(use_with mhash mhash)
+ $(use_with !mhash gcrypt)
+ $(use_with audit)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ readme.gentoo_create_doc
+
+ insinto /etc/${PN}
+ insopts -m0600
+ newins "${FILESDIR}"/aide.conf-r2 aide.conf
+
+ dosbin "${FILESDIR}"/aideinit
+ dodoc -r contrib/ "${FILESDIR}"/aide.cron-r2
+
+ keepdir /var/{lib,log}/${PN}
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/app-forensics/aide/aide-0.18.ebuild b/app-forensics/aide/aide-0.18.ebuild
new file mode 100644
index 000000000000..d444643eab3b
--- /dev/null
+++ b/app-forensics/aide/aide-0.18.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="AIDE (Advanced Intrusion Detection Environment) is a file integrity checker"
+HOMEPAGE="https://aide.github.io/ https://github.com/aide/aide"
+SRC_URI="https://github.com/aide/aide/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE="acl audit curl e2fs mhash selinux xattr"
+
+DEPEND="
+ dev-libs/libpcre2
+ sys-libs/zlib
+ acl? ( virtual/acl )
+ audit? ( sys-process/audit )
+ curl? ( net-misc/curl )
+ e2fs? ( sys-fs/e2fsprogs )
+ !mhash? (
+ dev-libs/libgcrypt:=
+ dev-libs/libgpg-error
+ )
+ mhash? ( app-crypt/mhash )
+ selinux? ( sys-libs/libselinux )
+ xattr? ( sys-apps/attr )
+"
+RDEPEND="
+ ${DEPEND}
+ selinux? ( sec-policy/selinux-aide )
+"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+"
+
+DISABLE_AUTOFORMATTING=1
+DOC_CONTENTS="
+Example configuration file was installed at '${EPREFIX}/etc/aide/aide.conf'.
+Please edit it to meet your needs. Refer to aide.conf(5) manual page
+for more information.
+
+A helper script, aideinit, was installed and can be used to make AIDE
+management easier. Please run 'aideinit --help' for more information."
+
+src_prepare() {
+ default
+
+ sed -i -e 's| -Werror||g' configure.ac || die
+
+ # Only needed for snapshots.
+ if [[ ${PV} == *_p* ]] ; then
+ echo "m4_define([AIDE_VERSION], [${PV}])" > version.m4 || die
+ fi
+}
+
+src_configure() {
+ # Needs Bison, flex
+ unset YACC
+ export LEX=flex
+
+ local myeconfargs=(
+ --sysconfdir="${EPREFIX}"/etc/${PN}
+
+ # Needed even in EAPI=8, >=portage-3.0.40 skips it here (bug #887177)
+ --disable-static
+
+ # Disable broken l10n support: https://sourceforge.net/p/aide/bugs/98/
+ # This doesn't affect anything because there are no localizations yet.
+ --without-locale
+
+ --with-zlib
+ $(use_with curl)
+ $(use_with acl posix-acl)
+ $(use_with selinux)
+ $(use_with xattr)
+ $(use_with e2fs e2fsattrs)
+ $(use_with mhash mhash)
+ $(use_with !mhash gcrypt)
+ $(use_with audit)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ readme.gentoo_create_doc
+
+ insinto /etc/${PN}
+ insopts -m0600
+ newins "${FILESDIR}"/aide.conf-r2 aide.conf
+
+ dosbin "${FILESDIR}"/aideinit
+ dodoc -r contrib/ "${FILESDIR}"/aide.cron-r2
+
+ keepdir /var/{lib,log}/${PN}
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/app-forensics/aide/files/aide-0.17.4-bashism.patch b/app-forensics/aide/files/aide-0.17.4-bashism.patch
deleted file mode 100644
index e25463dbf772..000000000000
--- a/app-forensics/aide/files/aide-0.17.4-bashism.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-Fixed upstream, so backport to 0.17.4 of
-https://github.com/aide/aide/commit/5161886c49060228811eee6da319844ef62dff6d
-https://github.com/aide/aide/commit/007eb4f32e8874ce457b4f15d9789c2a9d61731b
-
-Fixed in master but not 0.17.x.
---- a/configure.ac
-+++ b/configure.ac
-@@ -329,7 +329,7 @@ fi
- AC_CHECK_HEADERS(syslog.h inttypes.h fcntl.h ctype.h)
-
- PCRELIB="-lpcre"
--if test "$aide_static_choice" == "yes"; then
-+if test "$aide_static_choice" = "yes"; then
- PCRELIB="$PCRELIB -pthread"
- fi
- AC_CHECK_LIB(pcre, pcre_exec, [
-@@ -426,14 +426,14 @@ AS_IF([test "x$with_selinux_support" != xno],
- AC_DEFINE(WITH_SELINUX,1,[use SELinux])
- [AC_MSG_RESULT(yes)
- if test "x$PKG_CONFIG" != xno && $PKG_CONFIG --exists libselinux; then
-- if test "$aide_static_choice" == "yes"; then
-+ if test "$aide_static_choice" = "yes"; then
- SELINUXLIB=$(${PKG_CONFIG} --libs libselinux --static)
- else
- SELINUXLIB=$(${PKG_CONFIG} --libs libselinux)
- fi
- else
- SELINUXLIB="-lselinux"
-- if test "$aide_static_choice" == "yes"; then
-+ if test "$aide_static_choice" = "yes"; then
- saveLIBS=$LIBS
- LIBS="-static $SELINUXLIB"
- AC_SEARCH_LIBS([lgetfilecon_raw], [], [], [SELINUXLIB="$SELINUXLIB -lpthread"])
-@@ -555,7 +555,7 @@ AC_ARG_ENABLE([default_db],
- [do not set default values for database_in and database_out config options]),
- [enable_default_db=$enableval],[enable_default_db=yes])
-
--if test "$enable_default_db" == "yes"; then
-+if test "$enable_default_db" = "yes"; then
-
- if test "x$sysconfdir" != x'${prefix}/etc'; then
- evalled_sysconfdir=`eval echo "$sysconfdir"`
-@@ -592,7 +592,7 @@ AC_ARG_WITH([curl],
- [use curl library for http, https and ftp database backend (default: no)]),
- [with_curl=$withval], [with_curl=no])
- AS_IF([test "x$with_curl" = "xyes"], [
-- if test "$aide_static_choice" == "yes"; then
-+ if test "$aide_static_choice" = "yes"; then
- PKG_CHECK_MODULES_STATIC(CURL, [libcurl], , [AC_MSG_RESULT([libcurl not found by pkg-config - Try --without-curl or add directory containing libcurl.pc to PKG_CONFIG_PATH environment variable])])
- else
- PKG_CHECK_MODULES(CURL, [libcurl], , [AC_MSG_RESULT([libcurl not found by pkg-config - Try --without-curl or add directory containing libcurl.pc to PKG_CONFIG_PATH environment variable])])
-@@ -671,7 +671,7 @@ AS_IF([test "x$with_audit" != xno],
- AC_MSG_ERROR(You don't have libaudit properly installed. Install it if you need it.)
- )
- AUDITLIB="-laudit"
-- if test "$aide_static_choice" == "yes"; then
-+ if test "$aide_static_choice" = "yes"; then
- saveLIBS=$LIBS
- LIBS="-static $AUDITLIB"
- AC_CHECK_LIB([audit], [audit_log_user_message], [], [
diff --git a/app-forensics/aide/files/aide-0.17.4-configure.patch b/app-forensics/aide/files/aide-0.17.4-configure.patch
new file mode 100644
index 000000000000..adf9925d9458
--- /dev/null
+++ b/app-forensics/aide/files/aide-0.17.4-configure.patch
@@ -0,0 +1,131 @@
+https://github.com/aide/aide/pull/145
+https://bugs.gentoo.org/881707
+
+From 0a7f36406f3f21e4fcdc0c410ff626c352f2d080 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Fri, 18 Nov 2022 00:04:10 +0000
+Subject: [PATCH 1/2] Fix bashisms in build system
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+configure scripts need to be runnable with a POSIX-compliant /bin/sh.
+
+On many (but not all!) systems, /bin/sh is provided by Bash, so errors
+like this aren't spotted. Notably Debian defaults to /bin/sh provided
+by dash which doesn't tolerate such bashisms as '=='.
+
+This retains compatibility with bash.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/configure.ac
++++ b/configure.ac
+@@ -329,7 +329,7 @@ fi
+ AC_CHECK_HEADERS(syslog.h inttypes.h fcntl.h ctype.h)
+
+ PCRELIB="-lpcre"
+-if test "$aide_static_choice" == "yes"; then
++if test "$aide_static_choice" = "yes"; then
+ PCRELIB="$PCRELIB -pthread"
+ fi
+ AC_CHECK_LIB(pcre, pcre_exec, [
+@@ -426,14 +426,14 @@ AS_IF([test "x$with_selinux_support" != xno],
+ AC_DEFINE(WITH_SELINUX,1,[use SELinux])
+ [AC_MSG_RESULT(yes)
+ if test "x$PKG_CONFIG" != xno && $PKG_CONFIG --exists libselinux; then
+- if test "$aide_static_choice" == "yes"; then
++ if test "$aide_static_choice" = "yes"; then
+ SELINUXLIB=$(${PKG_CONFIG} --libs libselinux --static)
+ else
+ SELINUXLIB=$(${PKG_CONFIG} --libs libselinux)
+ fi
+ else
+ SELINUXLIB="-lselinux"
+- if test "$aide_static_choice" == "yes"; then
++ if test "$aide_static_choice" = "yes"; then
+ saveLIBS=$LIBS
+ LIBS="-static $SELINUXLIB"
+ AC_SEARCH_LIBS([lgetfilecon_raw], [], [], [SELINUXLIB="$SELINUXLIB -lpthread"])
+@@ -555,7 +555,7 @@ AC_ARG_ENABLE([default_db],
+ [do not set default values for database_in and database_out config options]),
+ [enable_default_db=$enableval],[enable_default_db=yes])
+
+-if test "$enable_default_db" == "yes"; then
++if test "$enable_default_db" = "yes"; then
+
+ if test "x$sysconfdir" != x'${prefix}/etc'; then
+ evalled_sysconfdir=`eval echo "$sysconfdir"`
+@@ -592,7 +592,7 @@ AC_ARG_WITH([curl],
+ [use curl library for http, https and ftp database backend (default: no)]),
+ [with_curl=$withval], [with_curl=no])
+ AS_IF([test "x$with_curl" = "xyes"], [
+- if test "$aide_static_choice" == "yes"; then
++ if test "$aide_static_choice" = "yes"; then
+ PKG_CHECK_MODULES_STATIC(CURL, [libcurl], , [AC_MSG_RESULT([libcurl not found by pkg-config - Try --without-curl or add directory containing libcurl.pc to PKG_CONFIG_PATH environment variable])])
+ else
+ PKG_CHECK_MODULES(CURL, [libcurl], , [AC_MSG_RESULT([libcurl not found by pkg-config - Try --without-curl or add directory containing libcurl.pc to PKG_CONFIG_PATH environment variable])])
+@@ -671,7 +671,7 @@ AS_IF([test "x$with_audit" != xno],
+ AC_MSG_ERROR(You don't have libaudit properly installed. Install it if you need it.)
+ )
+ AUDITLIB="-laudit"
+- if test "$aide_static_choice" == "yes"; then
++ if test "$aide_static_choice" = "yes"; then
+ saveLIBS=$LIBS
+ LIBS="-static $AUDITLIB"
+ AC_CHECK_LIB([audit], [audit_log_user_message], [], [
+
+From 67ad6efc7596c9b3ffdeb411bae942d757e2d96f Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Fri, 18 Nov 2022 00:04:53 +0000
+Subject: [PATCH 2/2] Fix configure.ac compatibility with Clang 16
+
+Clang 16 makes -Wimplicit-function-declaration and -Wimplicit-int errors by default.
+
+Unfortunately, this can lead to misconfiguration or miscompilation of software as configure
+tests may then return the wrong result.
+
+We also fix -Wstrict-prototypes while here as it's easy to do and it prepares
+us for C23.
+
+For more information, see LWN.net [0] or LLVM's Discourse [1], the Gentoo wiki [2],
+or the (new) c-std-porting mailing list [3].
+
+[0] https://lwn.net/Articles/913505/
+[1] https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213
+[2] https://wiki.gentoo.org/wiki/Modern_C_porting
+[3] hosted at lists.linux.dev.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/configure.ac
++++ b/configure.ac
+@@ -295,8 +295,11 @@ AC_CHECK_FUNCS(fcntl ftruncate posix_fadvise asprintf snprintf \
+ AC_CACHE_CHECK([for open/O_NOATIME], db_cv_open_o_noatime, [
+ echo "test for working open/O_NOATIME" > __o_noatime_file
+ AC_TRY_RUN([
+-#include <sys/types.h>
+ #include <fcntl.h>
++#include <stdlib.h>
++#include <sys/types.h>
++#include <sys/stat.h>
++#include <unistd.h>
+ #ifndef O_NOATIME
+ #if defined(__linux__) && (defined(__i386__) || defined(__PPC__))
+ #define O_NOATIME 01000000
+@@ -304,13 +307,14 @@ AC_TRY_RUN([
+ #define O_NOATIME 0
+ #endif
+ #endif
+-main() {
++int main(void) {
+ int c, fd = open("__o_noatime_file", O_RDONLY | O_NOATIME, 0);
+ exit ((!O_NOATIME) || (fd == -1) || (read(fd, &c, 1) != 1));
+ }], [db_cv_open_o_noatime=yes], [db_cv_open_o_noatime=no],
+ AC_TRY_LINK([
+-#include <sys/types.h>
+ #include <fcntl.h>
++#include <sys/types.h
++#include <sys/stat.h>
+ #ifndef O_NOATIME
+ #if defined(__linux__) && (defined(__i386__) || defined(__PPC__))
+ #define O_NOATIME 01000000
+