summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-forensics/ovaldi')
-rw-r--r--app-forensics/ovaldi/Manifest1
-rw-r--r--app-forensics/ovaldi/files/ovaldi-5.10.1.7-disable-acl.patch23
-rw-r--r--app-forensics/ovaldi/files/ovaldi-5.10.1.7-disable_RetrieveSelinuxDomainLabel.patch31
-rw-r--r--app-forensics/ovaldi/files/ovaldi-5.10.1.7-gcc11.patch72
-rw-r--r--app-forensics/ovaldi/metadata.xml8
-rw-r--r--app-forensics/ovaldi/ovaldi-5.10.1.7-r1.ebuild101
6 files changed, 0 insertions, 236 deletions
diff --git a/app-forensics/ovaldi/Manifest b/app-forensics/ovaldi/Manifest
deleted file mode 100644
index 10d46d80f07b..000000000000
--- a/app-forensics/ovaldi/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST ovaldi-5.10.1.7-src.tar.bz2 20391784 BLAKE2B 7e2c719f0819f967c6aee533bb881c29ffac756461460d73e3231f1cffd254d88a26e716f0334d023daa7fa6f9c314bf7a42b6c13e2a90daa558e589d135479c SHA512 22c373436889b03ffb5d479bd322703bbd8b5b335f116a3b38a3d206ddaaf3115961ab89597c3907b6e5d745eb302a042c135c73cde0eaae10e51f5d6e3e55ec
diff --git a/app-forensics/ovaldi/files/ovaldi-5.10.1.7-disable-acl.patch b/app-forensics/ovaldi/files/ovaldi-5.10.1.7-disable-acl.patch
deleted file mode 100644
index 0a8b5fa6a188..000000000000
--- a/app-forensics/ovaldi/files/ovaldi-5.10.1.7-disable-acl.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/src/probes/unix/FileProbe.cpp
-+++ b/src/probes/unix/FileProbe.cpp
-@@ -386,18 +386,8 @@
- 6) If a file has an ACL, the value will be 'true'.
- */
-
-- int hasExtendedAcl = acl_extended_file(filePath.c_str());
-- if(hasExtendedAcl > -1){ // behavior 4, 5, and 6
-- item->AppendElement(new ItemEntity("has_extended_acl",Common::ToString(hasExtendedAcl),OvalEnum::DATATYPE_BOOLEAN,OvalEnum::STATUS_EXISTS,0));
-- }else{
-- if(errno == EOPNOTSUPP){ // behavior 3
-- item->AppendElement(new ItemEntity("has_extended_acl","",OvalEnum::DATATYPE_BOOLEAN,OvalEnum::STATUS_DOES_NOT_EXIST,0));
-- }else{ // behavior 2
-- item->AppendElement(new ItemEntity("has_extended_acl","",OvalEnum::DATATYPE_BOOLEAN,OvalEnum::STATUS_ERROR,0));
-- item->AppendMessage(new OvalMessage(string("Error reading ACL data: ") + strerror(errno)));
-- }
-- }
--
-+ // behavior 1
-+ item->AppendElement(new ItemEntity("has_extended_acl","",OvalEnum::DATATYPE_BOOLEAN,OvalEnum::STATUS_NOT_COLLECTED,0));
- # else
- // behavior 1
- item->AppendElement(new ItemEntity("has_extended_acl","",OvalEnum::DATATYPE_BOOLEAN,OvalEnum::STATUS_NOT_COLLECTED,0));
diff --git a/app-forensics/ovaldi/files/ovaldi-5.10.1.7-disable_RetrieveSelinuxDomainLabel.patch b/app-forensics/ovaldi/files/ovaldi-5.10.1.7-disable_RetrieveSelinuxDomainLabel.patch
deleted file mode 100644
index 9f0a0e05e401..000000000000
--- a/app-forensics/ovaldi/files/ovaldi-5.10.1.7-disable_RetrieveSelinuxDomainLabel.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/src/probes/unix/Process58Probe.cpp
-+++ b/src/probes/unix/Process58Probe.cpp
-@@ -743,26 +743,8 @@
- }
-
- bool Process58Probe::RetrieveSelinuxDomainLabel(pid_t pid, string *label, string *err) {
-- security_context_t sctx;
-- int ec = getpidcon(pid, &sctx);
-- if (ec == -1) {
-- // getpidcon man page doesn't say errno is set... so we can't get a
-- // reason for the error.
-- *err = "getpidcon() failed";
-- return false;
-- }
--
-- SecurityContextGuard scg(sctx);
-- ContextGuard cg(sctx);
--
-- const char *tmp = context_type_get(cg);
-- if (!tmp) {
-- *err = string("context_get_type(")+sctx+"): "+strerror(errno);
-- return false;
-- }
--
-- *label = tmp;
-- return true;
-+ *err = string("context_get_type(NotImplmented)");
-+ return false;
- }
-
- #elif defined SUNOS
diff --git a/app-forensics/ovaldi/files/ovaldi-5.10.1.7-gcc11.patch b/app-forensics/ovaldi/files/ovaldi-5.10.1.7-gcc11.patch
deleted file mode 100644
index 1c71f7016d77..000000000000
--- a/app-forensics/ovaldi/files/ovaldi-5.10.1.7-gcc11.patch
+++ /dev/null
@@ -1,72 +0,0 @@
---- a/src/AbsProbe.cpp
-+++ b/src/AbsProbe.cpp
-@@ -52,7 +52,7 @@
- // use const wherever it makes sense, to ensure const-correctness??
- // Or maybe I should have implemented operator<() for items and
- // used the default std::less template...?
-- typedef set<Item*, std::less<const Item*> > ItemCache;
-+ typedef set<Item*, std::less<Item*> > ItemCache;
- ItemCache globalItemCache;
- }
-
---- a/src/ErrnoException.h
-+++ b/src/ErrnoException.h
-@@ -49,10 +49,10 @@
- SetErrorMessage(syscall+": "+std::strerror(errnoVal));
- }
-
-- virtual ~ErrnoException() throw () {
-+ virtual ~ErrnoException() {
- }
-
-- virtual const char* what() const throw() {
-+ virtual const char* what() const noexcept {
- return errorMessage.c_str();
- }
- };
---- a/src/OutOfMemoryException.h
-+++ b/src/OutOfMemoryException.h
-@@ -47,10 +47,10 @@
- : Exception(msg, severity, cause) {
- }
-
-- virtual ~OutOfMemoryException() throw () {
-+ virtual ~OutOfMemoryException() {
- }
-
-- virtual const char* what() const throw() {
-+ virtual const char* what() const noexcept {
- return errorMessage.c_str();
- }
- };
---- a/src/probes/unix/RunLevelProbe.cpp
-+++ b/src/probes/unix/RunLevelProbe.cpp
-@@ -125,7 +125,7 @@
-
-
- void
--RunLevelProbe::_verifyRunlevelObjectAttr( ObjectEntity * service_name, ObjectEntity * runlevel ) const throw( ProbeException ) {
-+RunLevelProbe::_verifyRunlevelObjectAttr( ObjectEntity * service_name, ObjectEntity * runlevel ) const {
-
- // check datatypes - only allow string
- if( service_name->GetDatatype() != OvalEnum::DATATYPE_STRING ){
---- a/src/probes/unix/RunLevelProbe.h
-+++ b/src/probes/unix/RunLevelProbe.h
-@@ -76,7 +76,7 @@
- */
- struct ltrunlevel_item_comparator
- {
-- bool operator() ( const runlevel_item &r1, const runlevel_item &r2 )
-+ bool operator() ( const runlevel_item &r1, const runlevel_item &r2 ) const
- {
- return r1.service_name.compare(r2.service_name) < 0;
- }
-@@ -115,7 +115,7 @@
- @param runlevel the runlevel runlevel_object entity
- @throws ProbeException if invalid operations or datatypes are encountered
- */
-- void _verifyRunlevelObjectAttr( ObjectEntity * service_name, ObjectEntity * runlevel ) const throw( ProbeException );
-+ void _verifyRunlevelObjectAttr( ObjectEntity * service_name, ObjectEntity * runlevel ) const;
-
- /**
- Checks to see if the given filename is either "." or ".."
diff --git a/app-forensics/ovaldi/metadata.xml b/app-forensics/ovaldi/metadata.xml
deleted file mode 100644
index 0011ef603d31..000000000000
--- a/app-forensics/ovaldi/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="sourceforge">ovaldi</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/app-forensics/ovaldi/ovaldi-5.10.1.7-r1.ebuild b/app-forensics/ovaldi/ovaldi-5.10.1.7-r1.ebuild
deleted file mode 100644
index 50a05b8d222f..000000000000
--- a/app-forensics/ovaldi/ovaldi-5.10.1.7-r1.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="Free implementation of OVAL"
-HOMEPAGE="http://oval.mitre.org/language/interpreter.html"
-SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.bz2"
-S="${WORKDIR}/${P}-src"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="acl ldap selinux"
-
-DEPEND="
- dev-libs/libgcrypt:=
- dev-libs/libpcre:=
- dev-libs/xalan-c:=
- dev-libs/xerces-c:=
- sys-apps/util-linux:=
- sys-libs/libcap
- acl? ( sys-apps/acl:= )
- ldap? ( net-nds/openldap:= )
- selinux? ( sys-libs/libselinux )"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- if ! use ldap ; then
- einfo "Disabling LDAP probes"
- sed -i 's,.*ldap,//&,' src/linux/ProbeFactory.cpp || die
- sed -i 's,.*LDAP,//&,' src/linux/ProbeFactory.cpp || die
- sed -i 's/-lldap//' project/linux/Makefile || die
- sed -i 's/-llber//' project/linux/Makefile || die
- sed -i 's/.*LDAPProbe.h.*//' src/linux/ProbeFactory.h || die
- rm src/probes/independent/LDAPProbe.{cpp,h} || die
- fi
-
- if ! use acl ; then
- sed -i 's,.*libacl,//&,' src/probes/unix/FileProbe.h || die
- eapply "${FILESDIR}"/${P}-disable-acl.patch
- sed -i 's, -lacl , ,' project/linux/Makefile || die
- fi
-
- einfo "Disabling rpm probes"
- sed -i 's/^PACKAGE_RPM/#PACKAGE_RPM/' project/linux/Makefile || die
-
- # same thing for dpkg, but package dpkg is not sufficient, needs app-arch/apt-pkg that is not on tree
- einfo "Disabling dpkg probes"
- sed -i 's/^PACKAGE_DPKG/#PACKAGE_DPKG/' project/linux/Makefile || die
-
- #Disabling SELinux support
- if ! use selinux ; then
- rm src/probes/linux/SelinuxSecurityContextProbe.cpp || die
- rm src/probes/linux/SelinuxBooleanProbe.cpp || die
- rm src/probes/linux/SelinuxBooleanProbe.h || die
- eapply "${FILESDIR}"/${P}-disable_RetrieveSelinuxDomainLabel.patch
- sed -i 's,.*selinux.*,//&,' src/linux/ProbeFactory.cpp || die
- sed -i 's,.*Selinux.*,//&,' src/linux/ProbeFactory.cpp || die
- sed -i 's,.*selinux.*.h.*,//&,' src/probes/unix/Process58Probe.cpp || die
- sed -i 's,.*SecurityContextGuard.h.*,//&,' src/probes/unix/Process58Probe.cpp || die
- sed -i 's, -lselinux,,' project/linux/Makefile || die
- fi
-
- # missing header for realloc and free
- sed -i 's,#include <unistd.h>,&\n#include <stdlib.h>,' src/linux/NetworkInterfaces.cpp || die
- sed -i 's,#include <unistd.h>,&\n#include <stdlib.h>,' src/linux/SystemInfo.cpp || die
-
- # respect CXX, CXXFLAGS and LDFLAGS
- sed -e '/^CPPFLAGS/s/$(INCDIRS)/$(CXXFLAGS) \0/' \
- -e 's/$(CXX) $^/$(CXX) $(LDFLAGS) $^/g' \
- -i project/linux/Makefile || die
-
- # no such library on linux
- sed -i 's,-lxalanMsg,,' project/linux/Makefile || die
-
- eapply "${FILESDIR}"/${P}-gcc11.patch
- eapply_user
-}
-
-src_configure() {
- tc-export CXX
-}
-
-src_compile() {
- emake -C project/linux
-}
-
-src_install() {
- # no make install in Makefile
- dosbin project/linux/Release/ovaldi project/linux/ovaldi.sh
- dodir /var/log/ovaldi
-
- insinto /usr/share/ovaldi
- doins -r xml/.
-
- dodoc docs/{README.txt,version.txt}
- doman docs/ovaldi.1
-}