summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/yara/Manifest1
-rw-r--r--app-forensics/yara/yara-4.2.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-forensics/yara/Manifest b/app-forensics/yara/Manifest
index 20a05f4273f6..0b041ee3099e 100644
--- a/app-forensics/yara/Manifest
+++ b/app-forensics/yara/Manifest
@@ -1,2 +1,3 @@
DIST yara-4.1.3.tar.gz 936462 BLAKE2B abfdd5918abe3641056ccde3eebb754cbd66eff5569978d3b1aad5d925d62fcb96b1f7367d0d014dd165db8634418259667be3b2441f93e0848bfbd905ca32dd SHA512 1bfa1787c62dfd9a87fa8db5e8c2fa68f082ae66b16b5373bdcc6bc66b32016fcaffd4baa7e59a7c1f6d3426c972eca9cc22f70d475067d7557b1014a4ab65fc
+DIST yara-4.2.0.tar.gz 1284022 BLAKE2B 34008b4d104f5034ac765480c26c0682462383866bf66cadcada4c77ae2a81cfddcf5f669ba1af607e9850aa9fe6371fea2383a659df5b0b7567153eeb76a67d SHA512 eb2bfefb14c9546af2f851395fe1a528199b27c1d967d453f929a116f8091a5e5714090b103c6049f5d8053bbd941bffd5d3865a7963cab5d7311fdcf5afbbac
DIST yara-4.2.0_rc1.tar.gz 1283822 BLAKE2B d7bf869e670a0223895aac31df0dbe063d3f0110d1981ae8a42ab26726976790c744b522f13a6963f521310a281fab2b27d6336b23e504a4a9a3d414473ae452 SHA512 03bd09d7c020078946101854e68b7f9ca17c04f7a68624e9e15dc476fe209cc11b010108a0e7aea9746f05aabdbb8d6a6a2ffc54516eb9cb86f170c4259934df
diff --git a/app-forensics/yara/yara-4.2.0.ebuild b/app-forensics/yara/yara-4.2.0.ebuild
new file mode 100644
index 000000000000..8bac51561719
--- /dev/null
+++ b/app-forensics/yara/yara-4.2.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A malware identification and classification tool"
+HOMEPAGE="http://virustotal.github.io/yara/"
+SRC_URI="https://github.com/virustotal/yara/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${PV/_/-}"
+
+LICENSE="Apache-2.0"
+SLOT="0/8"
+if [[ ${PV} != *_rc* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+IUSE="+dex +dotnet +cuckoo +macho +magic profiling python test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/openssl:=
+ cuckoo? ( dev-libs/jansson:= )
+ magic? ( sys-apps/file:= )
+"
+RDEPEND="${DEPEND}"
+PDEPEND="python? ( =dev-python/yara-python-$(ver_cut 1)* )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable profiling) \
+ $(use_enable cuckoo) \
+ $(use_enable magic) \
+ $(use_enable dotnet) \
+ $(use_enable macho) \
+ $(use_enable dex) \
+ $(use_enable test static)
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ default
+
+ # TODO: Allow tests to work against dyn. lib rather than building
+ # statically just for tests.
+ find "${ED}" -name '*.a' -delete || die
+}