summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/ibus-hangul/ibus-hangul-1.5.4.ebuild')
-rw-r--r--app-i18n/ibus-hangul/ibus-hangul-1.5.4.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/app-i18n/ibus-hangul/ibus-hangul-1.5.4.ebuild b/app-i18n/ibus-hangul/ibus-hangul-1.5.4.ebuild
index 4d13e3d9b116..e8b64f68faad 100644
--- a/app-i18n/ibus-hangul/ibus-hangul-1.5.4.ebuild
+++ b/app-i18n/ibus-hangul/ibus-hangul-1.5.4.ebuild
@@ -2,9 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
+PYTHON_COMPAT=( python3_{8..9} )
-PYTHON_COMPAT=( python3_{8,9} )
-inherit gnome2-utils python-single-r1 xdg
+inherit gnome2-utils python-single-r1 xdg virtualx
DESCRIPTION="Korean Hangul engine for IBus"
HOMEPAGE="https://github.com/libhangul/ibus-hangul/wiki"
@@ -27,12 +27,22 @@ DEPEND="${RDEPEND}"
BDEPEND="sys-devel/gettext
virtual/pkgconfig"
+PATCHES=( "${FILESDIR}"/${PN}-test.patch )
+
src_configure() {
econf \
$(use_enable nls) \
--with-python=${EPYTHON}
}
+src_test() {
+ "${BROOT}"${GLIB_COMPILE_SCHEMAS} --allow-any-name "${S}"/data || die
+
+ export GSETTINGS_BACKEND="memory"
+ export GSETTINGS_SCHEMA_DIR="${S}/data"
+ virtx default
+}
+
pkg_preinst() {
xdg_pkg_preinst
gnome2_schemas_savelist