summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/ibus-pinyin')
-rw-r--r--app-i18n/ibus-pinyin/files/ibus-pinyin-1.5.0-gettext.patch16
-rw-r--r--app-i18n/ibus-pinyin/files/ibus-pinyin-1.5.0-sqlite-3.41.0.patch23
-rw-r--r--app-i18n/ibus-pinyin/ibus-pinyin-1.5.0-r5.ebuild (renamed from app-i18n/ibus-pinyin/ibus-pinyin-1.5.0-r4.ebuild)7
-rw-r--r--app-i18n/ibus-pinyin/ibus-pinyin-1.5.0-r6.ebuild64
4 files changed, 107 insertions, 3 deletions
diff --git a/app-i18n/ibus-pinyin/files/ibus-pinyin-1.5.0-gettext.patch b/app-i18n/ibus-pinyin/files/ibus-pinyin-1.5.0-gettext.patch
new file mode 100644
index 000000000000..2014bad9820a
--- /dev/null
+++ b/app-i18n/ibus-pinyin/files/ibus-pinyin-1.5.0-gettext.patch
@@ -0,0 +1,16 @@
+--- a/setup/main.py
++++ b/setup/main.py
+@@ -45,7 +45,12 @@ class PreferencesDialog:
+ locale.setlocale(locale.LC_ALL, "")
+ localedir = os.getenv("IBUS_LOCALEDIR")
+ gettext.bindtextdomain("ibus-pinyin", localedir)
+- gettext.bind_textdomain_codeset("ibus-pinyin", "UTF-8")
++ # Python's gettext module doesn't provide all methods in
++ # new Python version since Python 3.10
++ try:
++ gettext.bind_textdomain_codeset("ibus-pinyin", "UTF-8")
++ except AttributeError:
++ pass
+
+ self.__bus = IBus.Bus()
+ self.__config = self.__bus.get_config()
diff --git a/app-i18n/ibus-pinyin/files/ibus-pinyin-1.5.0-sqlite-3.41.0.patch b/app-i18n/ibus-pinyin/files/ibus-pinyin-1.5.0-sqlite-3.41.0.patch
new file mode 100644
index 000000000000..0faa622e3230
--- /dev/null
+++ b/app-i18n/ibus-pinyin/files/ibus-pinyin-1.5.0-sqlite-3.41.0.patch
@@ -0,0 +1,23 @@
+UPSTREAM: https://github.com/ibus/ibus-pinyin/pull/12
+BUG: https://bugs.gentoo.org/896366
+AUTHOR: jinqiang zhang <peeweep@0x0.ee>
+
+As sqlite 3.41.0 release note say:
+
+ The double-quoted string misfeature is now disabled by default for CLI
+ builds. Legacy use cases can reenable the misfeature at run-time using
+ the ".dbconfig dqs_dml on" and ".dbconfig dqs_ddl on" commands.
+
+We should change this double quote to single quote
+
+--- a/data/db/english/english.awk
++++ b/data/db/english/english.awk
+@@ -16,7 +16,7 @@ BEGIN {
+ }
+
+ # Insert data into english table
+- { printf "INSERT INTO english (word, freq) VALUES (\"%s\", \"%f\");\n", $1, $2}
++ { printf "INSERT INTO english (word, freq) VALUES (\'%s\', %f);\n", $1, $2}
+
+ #quit sqlite3
+ END {
diff --git a/app-i18n/ibus-pinyin/ibus-pinyin-1.5.0-r4.ebuild b/app-i18n/ibus-pinyin/ibus-pinyin-1.5.0-r5.ebuild
index 0cff64748626..1084f11c4105 100644
--- a/app-i18n/ibus-pinyin/ibus-pinyin-1.5.0-r4.ebuild
+++ b/app-i18n/ibus-pinyin/ibus-pinyin-1.5.0-r5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2008-2022 Gentoo Authors
+# Copyright 2008-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
LUA_COMPAT=( lua5-1 )
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit autotools lua-single python-single-r1
@@ -31,7 +31,7 @@ RDEPEND="${PYTHON_DEPS}
DEPEND="${RDEPEND}"
BDEPEND="
dev-util/intltool
- sys-devel/autoconf-archive
+ dev-build/autoconf-archive
virtual/pkgconfig
nls? ( sys-devel/gettext )"
@@ -39,6 +39,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-boost.patch
"${FILESDIR}"/${P}-content-type-method.patch
"${FILESDIR}"/${P}-python3.patch
+ "${FILESDIR}"/${P}-sqlite-3.41.0.patch
)
pkg_setup() {
diff --git a/app-i18n/ibus-pinyin/ibus-pinyin-1.5.0-r6.ebuild b/app-i18n/ibus-pinyin/ibus-pinyin-1.5.0-r6.ebuild
new file mode 100644
index 000000000000..17c7102262c0
--- /dev/null
+++ b/app-i18n/ibus-pinyin/ibus-pinyin-1.5.0-r6.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2008-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+LUA_COMPAT=( lua5-1 )
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit autotools lua-single python-single-r1
+
+DESCRIPTION="Chinese Pinyin and Bopomofo engines for IBus"
+HOMEPAGE="https://github.com/ibus/ibus-pinyin"
+SRC_URI="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/ibus/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="boost lua nls"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ lua? ( ${LUA_REQUIRED_USE} )"
+
+RDEPEND="${PYTHON_DEPS}
+ app-i18n/pyzy
+ dev-db/sqlite:3
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ boost? ( dev-libs/boost )
+ lua? ( ${LUA_DEPS} )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ dev-build/autoconf-archive
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-boost.patch
+ "${FILESDIR}"/${P}-content-type-method.patch
+ "${FILESDIR}"/${P}-python3.patch
+ "${FILESDIR}"/${P}-sqlite-3.41.0.patch
+ "${FILESDIR}"/${P}-gettext.patch #905906
+)
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+
+ if use lua; then
+ lua-single_pkg_setup
+ fi
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable boost) \
+ $(use_enable lua lua-extension) \
+ $(use_enable nls)
+}