summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/ibus-typing-booster')
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.8.0.ebuild5
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.8.2.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.8.0.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.8.0.ebuild
index a1697767ab8d..ed1abe745449 100644
--- a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.8.0.ebuild
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.8.0.ebuild
@@ -5,7 +5,7 @@ EAPI="7"
PYTHON_COMPAT=( python3_{6,7,8} )
PYTHON_REQ_USE="sqlite(+)"
-inherit python-single-r1 xdg
+inherit gnome2-utils python-single-r1 xdg
DESCRIPTION="Completion input method for IBus"
HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
@@ -34,12 +34,15 @@ BDEPEND="sys-devel/gettext
pkg_preinst() {
xdg_pkg_preinst
+ gnome2_schemas_savelist
}
pkg_postinst() {
xdg_pkg_postinst
+ gnome2_schemas_update
}
pkg_postrm() {
xdg_pkg_postrm
+ gnome2_schemas_update
}
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.8.2.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.8.2.ebuild
index a1697767ab8d..ed1abe745449 100644
--- a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.8.2.ebuild
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.8.2.ebuild
@@ -5,7 +5,7 @@ EAPI="7"
PYTHON_COMPAT=( python3_{6,7,8} )
PYTHON_REQ_USE="sqlite(+)"
-inherit python-single-r1 xdg
+inherit gnome2-utils python-single-r1 xdg
DESCRIPTION="Completion input method for IBus"
HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
@@ -34,12 +34,15 @@ BDEPEND="sys-devel/gettext
pkg_preinst() {
xdg_pkg_preinst
+ gnome2_schemas_savelist
}
pkg_postinst() {
xdg_pkg_postinst
+ gnome2_schemas_update
}
pkg_postrm() {
xdg_pkg_postrm
+ gnome2_schemas_update
}