summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/kakasi/files/kakasi-2.3.6-configure-clang16.patch')
-rw-r--r--app-i18n/kakasi/files/kakasi-2.3.6-configure-clang16.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/app-i18n/kakasi/files/kakasi-2.3.6-configure-clang16.patch b/app-i18n/kakasi/files/kakasi-2.3.6-configure-clang16.patch
new file mode 100644
index 000000000000..7c6dd035f57c
--- /dev/null
+++ b/app-i18n/kakasi/files/kakasi-2.3.6-configure-clang16.patch
@@ -0,0 +1,19 @@
+https://src.fedoraproject.org/rpms/kakasi/raw/4756771349822d4ccd4d74a6ce70040ca57084cb/f/kakasi-configure-c99.patch
+https://bugs.gentoo.org/874654
+
+Avoid an implicit declaration of exit and build failures with future
+compilers which do not support implicit function declarations by
+default.
+
+--- a/configure.in
++++ b/configure.in
+@@ -85,7 +85,7 @@ AS_VAR_IF(utf8, "yes",[
+ LIBS="$LIBICONV $LIBS"
+ AC_DEFINE(KAKASI_SUPPORT_UTF8, 1, [KAKASI_SUPPORT_UTF8])
+ AC_RUN_IFELSE([AC_LANG_PROGRAM([#include <iconv.h>],
+- [if (iconv_open("EUC-JP", "UTF-8") == -1) exit(1);])],
++ [if (iconv_open("EUC-JP", "UTF-8") == -1) return 1;])],
+ [],
+ [AC_MSG_ERROR([can not use EUC-JP or UTF-8 encoding on iconv])])
+ ])
+