summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/scim-canna/scim-canna-1.0.1.ebuild')
-rw-r--r--app-i18n/scim-canna/scim-canna-1.0.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-i18n/scim-canna/scim-canna-1.0.1.ebuild b/app-i18n/scim-canna/scim-canna-1.0.1.ebuild
new file mode 100644
index 000000000000..0d8af91e191e
--- /dev/null
+++ b/app-i18n/scim-canna/scim-canna-1.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Japanese input method Canna IMEngine for SCIM"
+HOMEPAGE="http://scim-imengine.sourceforge.jp/index.cgi?cmd=view;name=SCIMCanna"
+SRC_URI="mirror://sourceforge.jp/scim-imengine/29155/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/scim-1.0
+ >=app-i18n/canna-3.7"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ elog
+ elog "To use SCIM with both GTK2 and XIM, you should use the following"
+ elog "in your user startup scripts such as .gnomerc or .xinitrc:"
+ elog
+ elog "LANG='your_language' scim -d"
+ elog "export GTK_IM_MODULE=scim"
+ elog "export QT_IM_MODULE=scim"
+ elog "export XMODIFIERS=@im=SCIM"
+ elog
+}