summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/scim-hangul/scim-hangul-0.3.2.ebuild')
-rw-r--r--app-i18n/scim-hangul/scim-hangul-0.3.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-i18n/scim-hangul/scim-hangul-0.3.2.ebuild b/app-i18n/scim-hangul/scim-hangul-0.3.2.ebuild
new file mode 100644
index 000000000000..132353f6d189
--- /dev/null
+++ b/app-i18n/scim-hangul/scim-hangul-0.3.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit base
+
+DESCRIPTION="Hangul IMEngine for SCIM ported from imhangul"
+HOMEPAGE="http://www.scim-im.org/"
+SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="nls"
+
+RDEPEND="|| ( >=app-i18n/scim-0.99.8 >=app-i18n/scim-cvs-0.99.8 )
+ >=app-i18n/libhangul-0.0.4
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}/${P}+gcc-4.3.patch"
+ "${FILESDIR}/${P}+gcc-4.7.patch" )
+
+src_configure() {
+ econf \
+ --disable-skim-support \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog* NEWS README*
+}
+
+pkg_postinst() {
+ elog
+ elog "To use SCIM with both GTK2 and XIM, you should use the following"
+ elog "in your user startup scripts such as .gnomerc or .xinitrc:"
+ elog
+ elog "LANG='your_language' scim -d"
+ elog "export XMODIFIERS=@im=SCIM"
+ elog
+}