summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/skkfep/skkfep-0.87-r1.ebuild')
-rw-r--r--app-i18n/skkfep/skkfep-0.87-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-i18n/skkfep/skkfep-0.87-r1.ebuild b/app-i18n/skkfep/skkfep-0.87-r1.ebuild
new file mode 100644
index 000000000000..86af3f3d2a88
--- /dev/null
+++ b/app-i18n/skkfep/skkfep-0.87-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A SKK-like Japanese input method for console"
+HOMEPAGE="http://homepage2.nifty.com/aito/soft.html"
+SRC_URI="http://homepage2.nifty.com/aito/skkfep/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+
+RDEPEND=">=sys-libs/ncurses-5.7-r7"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+ virtual/awk"
+RDEPEND="${RDEPEND}
+ app-i18n/skk-jisyo"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-LDFLAGS.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" OPTIMIZE="${CFLAGS}"
+}
+
+src_install() {
+ dobin skkfep escmode
+ doman skkfep.1
+ dodoc README HISTORY TODO
+}