summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/uchardet/uchardet-9999.ebuild')
-rw-r--r--app-i18n/uchardet/uchardet-9999.ebuild19
1 files changed, 13 insertions, 6 deletions
diff --git a/app-i18n/uchardet/uchardet-9999.ebuild b/app-i18n/uchardet/uchardet-9999.ebuild
index d694e455f2fe..031c6d829482 100644
--- a/app-i18n/uchardet/uchardet-9999.ebuild
+++ b/app-i18n/uchardet/uchardet-9999.ebuild
@@ -1,21 +1,28 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils git-r3
+inherit cmake
+if [ "${PV}" = 9999 ]
+then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/uchardet/uchardet.git"
+else
+ SRC_URI="https://www.freedesktop.org/software/uchardet/releases/${P}.tar.xz"
+fi
DESCRIPTION="An encoding detector library"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/uchardet/"
-EGIT_REPO_URI="https://anongit.freedesktop.org/git/uchardet/uchardet.git"
LICENSE="|| ( MPL-1.1 GPL-2+ LGPL-2.1+ )"
SLOT="0"
KEYWORDS=""
IUSE="cpu_flags_x86_sse2 static-libs test"
+RESTRICT="!test? ( test )"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
use test || cmake_comment_add_subdirectory test
}
@@ -25,5 +32,5 @@ src_configure() {
-DBUILD_STATIC=$(usex static-libs)
-DCHECK_SSE2=$(usex cpu_flags_x86_sse2)
)
- cmake-utils_src_configure
+ cmake_src_configure
}