summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-leechcraft/lc-core/lc-core-9999.ebuild')
-rw-r--r--app-leechcraft/lc-core/lc-core-9999.ebuild39
1 files changed, 22 insertions, 17 deletions
diff --git a/app-leechcraft/lc-core/lc-core-9999.ebuild b/app-leechcraft/lc-core/lc-core-9999.ebuild
index 8383dd36fa6c..1bd79f8b5ca2 100644
--- a/app-leechcraft/lc-core/lc-core-9999.ebuild
+++ b/app-leechcraft/lc-core/lc-core-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
EGIT_REPO_URI="https://github.com/0xd34df00d/leechcraft.git"
@@ -11,47 +11,52 @@ DESCRIPTION="Core of LeechCraft, the modular network client"
SLOT="0"
KEYWORDS=""
-IUSE="debug doc +sqlite postgres +qwt"
+IUSE="debug doc postgres +qwt +sqlite"
-COMMON_DEPEND=">=dev-libs/boost-1.62
+DEPEND="
+ >=dev-libs/boost-1.62
+ dev-qt/qtconcurrent:5
dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtxml:5
+ dev-qt/qtdbus:5
dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
dev-qt/qtscript:5
dev-qt/qtsql:5[postgres?,sqlite?]
- dev-qt/qtdbus:5
dev-qt/qtwebkit:5
- dev-qt/qtnetwork:5
dev-qt/qtwidgets:5
dev-qt/qtx11extras:5
- dev-qt/qtconcurrent:5
- dev-qt/linguist-tools:5
- qwt? ( x11-libs/qwt:6 )"
-DEPEND="${COMMON_DEPEND}
- doc? ( app-doc/doxygen )"
-RDEPEND="${COMMON_DEPEND}
+ dev-qt/qtxml:5
+ qwt? ( x11-libs/qwt:6 )
+"
+RDEPEND="${DEPEND}
dev-qt/qtsvg:5
|| (
kde-frameworks/oxygen-icons
x11-themes/kfaenza
- )"
+ )
+"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ doc? ( app-doc/doxygen )
+"
REQUIRED_USE="|| ( postgres sqlite )"
src_configure() {
local mycmakeargs=(
-DWITH_PLUGINS=False
+ -DSKIP_MAN_COMPRESS=True
-DWITH_DOCS=$(usex doc)
-DWITH_QWT=$(usex qwt)
)
if [[ ${PV} != 9999 ]]; then
mycmakeargs+=( -DLEECHCRAFT_VERSION=${PV} )
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
use doc && dodoc -r "${CMAKE_BUILD_DIR}/${PN#lc-}"/out/html/*
}