summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-leechcraft/lcpackgen/lcpackgen-1.3.ebuild')
-rw-r--r--app-leechcraft/lcpackgen/lcpackgen-1.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-leechcraft/lcpackgen/lcpackgen-1.3.ebuild b/app-leechcraft/lcpackgen/lcpackgen-1.3.ebuild
new file mode 100644
index 000000000000..1a8f746ba3f0
--- /dev/null
+++ b/app-leechcraft/lcpackgen/lcpackgen-1.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit cmake-utils
+
+DESCRIPTION="Package creator for app-leechcraft/lc-lackman package manager"
+
+SRC_URI="https://github.com/0xd34df00d/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+HOMEPAGE="http://leechcraft.org/"
+LICENSE="Boost-1.0"
+
+CMAKE_USE_DIR="${S}"/src
+
+COMMON_DEPEND=">=dev-libs/boost-1.46
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtxmlpatterns:4"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}
+ dev-qt/qtsvg:4"