summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/ansiweather')
-rw-r--r--app-misc/ansiweather/Manifest1
-rw-r--r--app-misc/ansiweather/ansiweather-1.19.0.ebuild36
-rw-r--r--app-misc/ansiweather/metadata.xml18
3 files changed, 55 insertions, 0 deletions
diff --git a/app-misc/ansiweather/Manifest b/app-misc/ansiweather/Manifest
new file mode 100644
index 000000000000..326140e0e9de
--- /dev/null
+++ b/app-misc/ansiweather/Manifest
@@ -0,0 +1 @@
+DIST ansiweather-1.19.0.tar.gz 14232 BLAKE2B b32cf2f4706759f296d5bb725627593a2dc3311bbc957a33cdebf6f7c36245006c84099d7437ee06fb39e8122d8ed5e532bdeefeae2a4d35ae741c2ec81bc2f2 SHA512 1dc521c904041a698fbb1a3a78f5a0b7d5bdc731258ab9cc384ee1a9f750c60723b0038288d7d98875672d167614f7bb8ca69ff1f7d38a28d52916afd5bda0a2
diff --git a/app-misc/ansiweather/ansiweather-1.19.0.ebuild b/app-misc/ansiweather/ansiweather-1.19.0.ebuild
new file mode 100644
index 000000000000..3d165691bb23
--- /dev/null
+++ b/app-misc/ansiweather/ansiweather-1.19.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Weather in terminal, with ANSI colors and Unicode symbols"
+HOMEPAGE="https://github.com/fcambus/ansiweather/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/fcambus/${PN}.git"
+else
+ SRC_URI="https://github.com/fcambus/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="amd64 ~x86"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="
+ app-misc/jq
+ app-alternatives/bc
+ || ( net-misc/curl net-ftp/ftp net-misc/wget )
+"
+
+DOCS=( AUTHORS ChangeLog README.md ansiweatherrc.example )
+
+src_install() {
+ exeinto /usr/bin
+ doexe ${PN}
+
+ doman ${PN}.1
+
+ einstalldocs
+}
diff --git a/app-misc/ansiweather/metadata.xml b/app-misc/ansiweather/metadata.xml
new file mode 100644
index 000000000000..be381fee57b7
--- /dev/null
+++ b/app-misc/ansiweather/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ AnsiWeather is a Shell script for displaying the current weather conditions
+ in your terminal, with support for ANSI colors and Unicode symbols.
+ </longdescription>
+ <upstream>
+ <changelog>https://raw.githubusercontent.com/fcambus/ansiweather/master/ChangeLog</changelog>
+ <bugs-to>https://github.com/fcambus/ansiweather/issues</bugs-to>
+ <remote-id type="github">fcambus/ansiweather</remote-id>
+ </upstream>
+</pkgmetadata>