summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/astrolog')
-rw-r--r--app-misc/astrolog/Manifest1
-rw-r--r--app-misc/astrolog/astrolog-7.40.ebuild4
-rw-r--r--app-misc/astrolog/astrolog-7.60.ebuild (renamed from app-misc/astrolog/astrolog-5.40-r3.ebuild)33
-rw-r--r--app-misc/astrolog/files/astrolog-7.60-drop-resiters.patch36
4 files changed, 54 insertions, 20 deletions
diff --git a/app-misc/astrolog/Manifest b/app-misc/astrolog/Manifest
index 38a8d0dafb89..905de738fda6 100644
--- a/app-misc/astrolog/Manifest
+++ b/app-misc/astrolog/Manifest
@@ -1,2 +1 @@
-DIST ast54unx.shr 1465432 BLAKE2B 9eec58fb66110a7fd072eee8b02dda109a22c1a1d59506943011041ab595e33eac39f5372ab55f587bcdfb447e599b16b8a9f0ccd04c54257b0dd38a85acde08 SHA512 824fcea1891dafc77692e84a36cc97a8afd90ad93d772edab8437e89869cdc912002f628fd86eecc8182ba4f1ad02cb98f42a30fde425bf94cf59f852b4eda1a
DIST ast74src.zip 4483648 BLAKE2B d15d3e5d98337c5c5884973d079cffda9144a5c9f43ab48dd38f782eeef089d9fd5fb3f5a01f1d607bd2134e6a774494d4cf7d99e117d3092c8787626436e778 SHA512 540bda7ee10cde0723f6bd4afe410e4e9c59168e31dbdbd0b3b62a9e77ae83a971543fc812876258e2b7b9636f880c74b9be5497c54e7dd0e9b444bad2edbf6b
diff --git a/app-misc/astrolog/astrolog-7.40.ebuild b/app-misc/astrolog/astrolog-7.40.ebuild
index ede487c65b7d..ab421e0eb9aa 100644
--- a/app-misc/astrolog/astrolog-7.40.ebuild
+++ b/app-misc/astrolog/astrolog-7.40.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+# Please bump with app-misc/astrolog-ephemeris
+
inherit toolchain-funcs
DESCRIPTION="A many featured astrology chart calculation program"
@@ -11,7 +13,7 @@ SRC_URI="https://www.astrolog.org/ftp/ast74src.zip"
LICENSE="astrolog"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+KEYWORDS="amd64 ppc ppc64 x86"
IUSE="X"
DEPEND="X? ( x11-libs/libX11 )"
diff --git a/app-misc/astrolog/astrolog-5.40-r3.ebuild b/app-misc/astrolog/astrolog-7.60.ebuild
index 04fdcd95eae3..4390bd12d028 100644
--- a/app-misc/astrolog/astrolog-5.40-r3.ebuild
+++ b/app-misc/astrolog/astrolog-7.60.ebuild
@@ -1,13 +1,15 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
+# Please bump with app-misc/astrolog-ephemeris
inherit toolchain-funcs
DESCRIPTION="A many featured astrology chart calculation program"
-HOMEPAGE="http://www.astrolog.org/astrolog.htm"
-SRC_URI="http://www.astrolog.org/ftp/ast54unx.shr"
+HOMEPAGE="https://www.astrolog.org/astrolog.htm"
+SRC_URI="https://www.astrolog.org/ftp/ast74src.zip"
LICENSE="astrolog"
SLOT="0"
@@ -16,12 +18,13 @@ IUSE="X"
DEPEND="X? ( x11-libs/libX11 )"
RDEPEND="${DEPEND}"
+BDEPEND="app-arch/unzip"
S="${WORKDIR}"
-src_unpack() {
- sh "${DISTDIR}"/ast54unx.shr || die
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-7.60-drop-resiters.patch
+)
src_prepare() {
default
@@ -36,17 +39,11 @@ src_prepare() {
# we use /usr/share/astrolog for config and (optional) ephemeris-data-files
sed -i -e "s:~/astrolog:/usr/share/astrolog:g" astrolog.h || die
- # if we use X, we need to add -L/usr/X11R6/lib to compile succesful
- #use X && sed -i -e "s:-lm -lX11:-lm -lX11 -L/usr/X11R6/lib:g" Makefile
-
# if we do NOT use X, we disable it by removing the -lX11 from the Makefile
# and remove the "#define X11" and "#define MOUSE" from astrolog.h
use X || ( sed -i -e "s:-lm -lX11:-lm:g" Makefile || die
sed -i -e "s:#define X11:/*#define X11:g" astrolog.h || die
sed -i -e "s:#define MOUSE:/*#define MOUSE:g" astrolog.h || die)
-
- # any user may have an own astrolog configfile
- #sed -i -e "s:astrolog.dat:astrolog.dat:g" astrolog.h || die
}
src_compile() {
@@ -55,16 +52,16 @@ src_compile() {
src_install() {
dobin astrolog
- dodoc Helpfile.540 README.1ST README.540 Update.540
+ dodoc astrolog.doc changes.doc
insinto /usr/share/astrolog
- doins astrolog.dat
+ doins astrolog.as
}
pkg_postinst() {
- elog "There is a sample config file /usr/share/astrolog/astrolog.dat"
- elog "astrolog looks in current dir for a file astrolog.dat before"
+ elog "There is a sample config file /usr/share/astrolog/astrolog.as"
+ elog "astrolog looks in current dir for a file astrolog.as before"
elog "using the file in /usr/share/astrolog"
elog "If you want extended accuracy of astrolog's calculations you"
elog "can emerge the optional package \"astrolog-ephemeris\" which"
- elog "needs ~4.7 MB additional diskspace for the ephemeris-files"
+ elog "needs ~32.9 MB additional diskspace for the ephemeris-files"
}
diff --git a/app-misc/astrolog/files/astrolog-7.60-drop-resiters.patch b/app-misc/astrolog/files/astrolog-7.60-drop-resiters.patch
new file mode 100644
index 000000000000..ae399f8e099d
--- /dev/null
+++ b/app-misc/astrolog/files/astrolog-7.60-drop-resiters.patch
@@ -0,0 +1,36 @@
+Bug: https://bugs.gentoo.org/894524
+Sent patch upstream, dev said they will take it in coming version,
+https://github.com/CruiserOne/Astrolog/pull/20#issuecomment-1666693982
+--- a/placalc.cpp
++++ b/placalc.cpp
+@@ -561,8 +561,8 @@ int hel(int planet, REAL8 t, REAL8 *al, REAL8 *ar, REAL8 *az, REAL8 *alp,
+ /* speed in radius, AU per day */
+ /* speed in z, AU per day */
+ {
+- register struct elements *e;
+- register struct eledata *d;
++ struct elements *e;
++ struct eledata *d;
+ REAL8 lk = 0.0;
+ REAL8 rk = 0.0;
+ REAL8 b, h1, sini, sinv, cosi, cosu, cosv, man, truanom, esquare,
+@@ -686,7 +686,7 @@ int hel(int planet, REAL8 t, REAL8 *al, REAL8 *ar, REAL8 *az, REAL8 *alp,
+ }
+
+
+-void disturb(register struct kor *k, REAL8 *al, REAL8 *ar, REAL8 lk, REAL8 rk,
++void disturb(struct kor *k, REAL8 *al, REAL8 *ar, REAL8 lk, REAL8 rk,
+ REAL8 man)
+ /* ENDMARK-terminated array of struct kor */
+ /* longitude in degrees, use a pointer to return value */
+--- a/placalc.h
++++ b/placalc.h
+@@ -256,7 +256,7 @@ extern REAL8 test_near_zero(REAL8);
+ extern REAL8 deltat(double);
+ extern void to_mean_ekl();
+ extern int afl2planet();
+-extern void disturb(register struct kor *, REAL8 *, REAL8 *, REAL8, REAL8,
++extern void disturb(struct kor *, REAL8 *, REAL8 *, REAL8, REAL8,
+ REAL8);
+ extern REAL8 fnu(REAL8, REAL8, REAL8);
+