summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/binwalk/binwalk-9999.ebuild')
-rw-r--r--app-misc/binwalk/binwalk-9999.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/app-misc/binwalk/binwalk-9999.ebuild b/app-misc/binwalk/binwalk-9999.ebuild
index d819647e95dc..7c288ad1f32b 100644
--- a/app-misc/binwalk/binwalk-9999.ebuild
+++ b/app-misc/binwalk/binwalk-9999.ebuild
@@ -1,19 +1,19 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-DISTUTILS_USE_SETUPTOOLS=bdepend
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/ReFirmLabs/binwalk.git"
inherit git-r3
else
SRC_URI="https://github.com/ReFirmLabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~x64-macos"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~x64-macos"
fi
DESCRIPTION="A tool for identifying files embedded inside firmware images"
@@ -22,9 +22,12 @@ HOMEPAGE="https://github.com/ReFirmLabs/binwalk"
LICENSE="MIT"
SLOT="0"
-PATCHES=( "${FILESDIR}"/${PN}-2.2.0-disable-test-coverage.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2.0-disable-test-coverage.patch
-distutils_enable_tests --install nose
+)
+
+distutils_enable_tests nose
python_install_all() {
local DOCS=( API.md INSTALL.md README.md )