summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/birthday')
-rw-r--r--app-misc/birthday/birthday-1.6.2-r1.ebuild30
-rw-r--r--app-misc/birthday/birthday-1.6.2-r2.ebuild20
-rw-r--r--app-misc/birthday/files/birthday-1.6.2-makefile.patch44
-rw-r--r--app-misc/birthday/metadata.xml2
4 files changed, 65 insertions, 31 deletions
diff --git a/app-misc/birthday/birthday-1.6.2-r1.ebuild b/app-misc/birthday/birthday-1.6.2-r1.ebuild
deleted file mode 100644
index 94556795d5e8..000000000000
--- a/app-misc/birthday/birthday-1.6.2-r1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-DESCRIPTION="Displays a list of events happening in the near future"
-HOMEPAGE="https://sourceforge.net/projects/birthday/"
-SRC_URI="mirror://sourceforge/birthday/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 sparc x86"
-
-src_prepare() {
- # Don't strip, install in correct share dir and respect CFLAGS
- sed \
- -e "s:install -s:install:g" -e "s:#SHARE:SHARE:g" -e "s:-O2:${CFLAGS}:g" \
- -i Makefile || die
- sed \
- -e 's:grep -v:grep --binary-files=text -v:g' \
- -i runtest.sh || die
-
- default
-}
-
-src_compile() {
- emake CC=$(tc-getCC)
-}
diff --git a/app-misc/birthday/birthday-1.6.2-r2.ebuild b/app-misc/birthday/birthday-1.6.2-r2.ebuild
new file mode 100644
index 000000000000..538b8bac4bbf
--- /dev/null
+++ b/app-misc/birthday/birthday-1.6.2-r2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Displays a list of events happening in the near future"
+HOMEPAGE="https://sourceforge.net/projects/birthday/"
+SRC_URI="https://downloads.sourceforge.net/birthday/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+
+src_configure() {
+ tc-export CC
+}
diff --git a/app-misc/birthday/files/birthday-1.6.2-makefile.patch b/app-misc/birthday/files/birthday-1.6.2-makefile.patch
new file mode 100644
index 000000000000..f48102d929b7
--- /dev/null
+++ b/app-misc/birthday/files/birthday-1.6.2-makefile.patch
@@ -0,0 +1,44 @@
+--- a/Makefile
++++ b/Makefile
+@@ -12,7 +12,7 @@
+ else
+ OSCFLAGS=-Wall -Wstrict-prototypes
+ endif
+-CFLAGS=-O2 $(DEBUG) -D$(OS) $(OSCFLAGS)
++CFLAGS += $(DEBUG) -D$(OS) $(OSCFLAGS)
+
+ # engine
+ ENGSRC=bdengine.c xmalloc.c
+@@ -48,16 +48,15 @@
+
+ else
+ birthday: $(CMDOBJ)
+- $(CC) $(LDFLAGS) $(CMDOBJ) -o $@
++ $(CC) $(LDFLAGS) $(CMDOBJ) -o $@ $(LIBS)
+
+ # you can override this to use the new FHS locations.
+-SHARE=
+-#SHARE=/share
++SHARE=/share
+
+ install: birthday birthday.man
+- install -d $(DESTDIR)/usr/bin $(DESTDIR)/usr$(SHARE)/man/man1
+- install -s birthday $(DESTDIR)/usr/bin/birthday
+- install -m 0644 birthday.man $(DESTDIR)/usr$(SHARE)/man/man1/birthday.1
++ install -d $(DESTDIR)$(EPREFIX)/usr/bin $(DESTDIR)$(EPREFIX)/usr$(SHARE)/man/man1
++ install birthday $(DESTDIR)$(EPREFIX)/usr/bin/birthday
++ install -m 0644 birthday.man $(DESTDIR)$(EPREFIX)/usr$(SHARE)/man/man1/birthday.1
+
+ test: birthday
+ sh runtest.sh -exec `pwd`/birthday test/*.t
+--- a/runtest.sh
++++ b/runtest.sh
+@@ -7,7 +7,7 @@
+ unset PASSED FAILED TAKEN KEEP
+
+ extract_section() {
+- sed -ne "/^\\*$1/,/^\\*/p" "$2" | grep -v '^*'
++ sed -ne "/^\\*$1/,/^\\*/p" "$2" | grep --binary-files=text -v '^*'
+ }
+
+ runtest() {
diff --git a/app-misc/birthday/metadata.xml b/app-misc/birthday/metadata.xml
index 6461f9f10b33..a6089789d36b 100644
--- a/app-misc/birthday/metadata.xml
+++ b/app-misc/birthday/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>shell-tools@gentoo.org</email>