summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/bottlerocket/bottlerocket-0.04c-r2.ebuild')
-rw-r--r--app-misc/bottlerocket/bottlerocket-0.04c-r2.ebuild28
1 files changed, 12 insertions, 16 deletions
diff --git a/app-misc/bottlerocket/bottlerocket-0.04c-r2.ebuild b/app-misc/bottlerocket/bottlerocket-0.04c-r2.ebuild
index dbc423b04cb7..fef8fe2c07ac 100644
--- a/app-misc/bottlerocket/bottlerocket-0.04c-r2.ebuild
+++ b/app-misc/bottlerocket/bottlerocket-0.04c-r2.ebuild
@@ -1,39 +1,35 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit toolchain-funcs
+inherit autotools
DESCRIPTION="CLI interface to the X-10 Firecracker Kit"
-HOMEPAGE="http://www.linuxha.com/bottlerocket/"
-SRC_URI="http://www.linuxha.com/${PN}/${P}.tar.gz"
+HOMEPAGE="https://www.linuxha.com/bottlerocket/"
+SRC_URI="https://www.linuxha.com/${PN}/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
-IUSE=""
KEYWORDS="amd64 ~ppc ~sparc x86"
src_prepare() {
default
- # inset LDFLAGS
- sed -i Makefile.in \
- -e 's| -O2 ||g' \
- -e '/ -o br /s|${CFLAGS}|& $(LDFLAGS)|g' \
- || die "sed Makefile.in"
+
+ sed -e 's| -O2 ||' \
+ -e '/ -o br /s|${CFLAGS}|& $(CPPFLAGS) $(LDFLAGS)|' \
+ -i Makefile.in || die
+
+ eautoreconf #874321
}
src_configure() {
econf --with-x10port=/dev/firecracker
}
-src_compile() {
- emake CC="$(tc-getCC)"
-}
-
src_install() {
- dodoc README
dobin br
+ dodoc README
}
pkg_postinst() {