summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/cdargs/cdargs-1.35-r2.ebuild')
-rw-r--r--app-misc/cdargs/cdargs-1.35-r2.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/app-misc/cdargs/cdargs-1.35-r2.ebuild b/app-misc/cdargs/cdargs-1.35-r2.ebuild
index 28fca19b1a63..49a232fae2de 100644
--- a/app-misc/cdargs/cdargs-1.35-r2.ebuild
+++ b/app-misc/cdargs/cdargs-1.35-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit autotools elisp-common eutils
+inherit autotools elisp-common
DESCRIPTION="Bookmarks and browser for the shell builtin cd command"
HOMEPAGE="http://www.skamphausen.de/cgi-bin/ska/CDargs"
@@ -16,7 +16,8 @@ IUSE="emacs"
DEPEND="
sys-libs/ncurses:0=
- emacs? ( virtual/emacs )"
+ emacs? ( >=app-editors/emacs-23.1:* )
+"
RDEPEND="${DEPEND}"
SITEFILE=50${PN}-gentoo.el
@@ -24,10 +25,11 @@ SITEFILE=50${PN}-gentoo.el
PATCHES=(
"${FILESDIR}"/${P}-format_security.patch
"${FILESDIR}"/${P}-tinfo.patch
- )
+)
src_prepare() {
- epatch "${PATCHES[@]}"
+ default
+
mv configure.{in,ac} || die
eautoreconf
}
@@ -41,12 +43,13 @@ src_compile() {
src_install() {
default
- cd "${S}/contrib" || die
+ cd "${S}"/contrib || die
insinto /usr/share/cdargs
doins cdargs-bash.sh cdargs-tcsh.csh
+
if use emacs ; then
elisp-install ${PN} cdargs.{el,elc}
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
fi
}