summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/chkcrontab/chkcrontab-1.7-r3.ebuild')
-rw-r--r--app-misc/chkcrontab/chkcrontab-1.7-r3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-misc/chkcrontab/chkcrontab-1.7-r3.ebuild b/app-misc/chkcrontab/chkcrontab-1.7-r3.ebuild
new file mode 100644
index 000000000000..8c5c3735dc75
--- /dev/null
+++ b/app-misc/chkcrontab/chkcrontab-1.7-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1
+
+DESCRIPTION="A tool to detect crontab errors"
+HOMEPAGE="https://github.com/lyda/chkcrontab"
+SRC_URI="https://github.com/lyda/chkcrontab/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/${PN}-man.patch"
+ "${FILESDIR}/${PN}-py312.patch"
+)
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -i 's/assertEquals/assertEqual/g' tests/test_check.py || die
+}
+
+python_install_all() {
+ doman doc/${PN}.1
+ distutils-r1_python_install_all
+}