summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/chkcrontab/files')
-rw-r--r--app-misc/chkcrontab/files/chkcrontab-man.patch12
-rw-r--r--app-misc/chkcrontab/files/chkcrontab-py312.patch23
2 files changed, 35 insertions, 0 deletions
diff --git a/app-misc/chkcrontab/files/chkcrontab-man.patch b/app-misc/chkcrontab/files/chkcrontab-man.patch
new file mode 100644
index 000000000000..83e4a41e1b48
--- /dev/null
+++ b/app-misc/chkcrontab/files/chkcrontab-man.patch
@@ -0,0 +1,12 @@
+diff --git a/setup.py b/setup.py
+index df72a6a..b2082c6 100755
+--- a/setup.py
++++ b/setup.py
+@@ -143,6 +143,7 @@ class InstallCmd(install):
+
+ def run(self):
+ install.run(self)
++ return
+ manpages = ['doc/chkcrontab.1']
+ if self.manprefix:
+ for manpage in manpages:
diff --git a/app-misc/chkcrontab/files/chkcrontab-py312.patch b/app-misc/chkcrontab/files/chkcrontab-py312.patch
new file mode 100644
index 000000000000..b384549b3489
--- /dev/null
+++ b/app-misc/chkcrontab/files/chkcrontab-py312.patch
@@ -0,0 +1,23 @@
+# https://github.com/gregorg/chkcrontab/pull/1
+diff --git a/chkcrontab_lib.py b/chkcrontab_lib.py
+index 57a7c1f..6334a77 100755
+--- a/chkcrontab_lib.py
++++ b/chkcrontab_lib.py
+@@ -822,12 +822,12 @@ def ParseLine(self, line, options ):
+ Returns:
+ A CronLine* class (must have a ValidateAndLog method).
+ """
+- chkcrontab_cmd = re.compile('##*\s*chkcrontab:\s*(.*)=(.*)')
+- assignment_line_re = re.compile('[a-zA-Z_][a-zA-Z0-9_]*\s*=(.*)')
+- at_line_re = re.compile('@(\S+)\s+(\S+)\s+(.*)')
+- cron_time_field_re = '[\*0-9a-zA-Z,/-]+'
++ chkcrontab_cmd = re.compile(r'##*\s*chkcrontab:\s*(.*)=(.*)')
++ assignment_line_re = re.compile(r'[a-zA-Z_][a-zA-Z0-9_]*\s*=(.*)')
++ at_line_re = re.compile(r'@(\S+)\s+(\S+)\s+(.*)')
++ cron_time_field_re = r'[\*0-9a-zA-Z,/-]+'
+ time_field_job_line_re = re.compile(
+- '^\s*(%s)\s+(%s)\s+(%s)\s+(%s)\s+(%s)\s+(\S+)\s+(.*)' %
++ r'^\s*(%s)\s+(%s)\s+(%s)\s+(%s)\s+(%s)\s+(\S+)\s+(.*)' %
+ (cron_time_field_re, cron_time_field_re, cron_time_field_re,
+ cron_time_field_re, cron_time_field_re))
+