summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/countrycodes/files')
-rw-r--r--app-misc/countrycodes/files/1.0.5-Makefile.patch42
-rw-r--r--app-misc/countrycodes/files/1.0.6-Makefile.patch35
2 files changed, 35 insertions, 42 deletions
diff --git a/app-misc/countrycodes/files/1.0.5-Makefile.patch b/app-misc/countrycodes/files/1.0.5-Makefile.patch
deleted file mode 100644
index 677e59acc5c0..000000000000
--- a/app-misc/countrycodes/files/1.0.5-Makefile.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 9330578..3ff7319 100644
---- a/Makefile
-+++ b/Makefile
-@@ -26,13 +26,13 @@ BINMODE=755
- LOGDIRMODE=700
-
- # Compiler to use
--CC=gcc
-+CC ?= gcc
-
- # Compiler warnings
--WARNINGS= -pedantic -Wall
-+WARNINGS=
-
- # Compiler flags
--CCOPTS = -O2 -fomit-frame-pointer
-+CCOPTS = ${CFLAGS}
-
- # The makefile standards document I read says that I have to put it here...
- SHELL = /bin/sh
-@@ -61,7 +61,7 @@ PROGRAM = iso3166
- all: $(PROGRAM)
-
- $(PROGRAM): $(ISO3166OBJ)
-- $(CC) $(CCOPTS) $(ISO3166OBJ) -o $@
-+ $(CC) $(CCOPTS) $(LDFLAGS) $(ISO3166OBJ) -o $@
-
- clean:
- rm -f $(ISO3166OBJ) core defines.h $(PROGRAM)
-@@ -70,8 +70,10 @@ strip:
- strip $(PROGRAM)
-
- install:
-- $(INSTALL) -g root -m $(BINMODE) -o root -s ${srcdir}/$(PROGRAM) ${bindir}
-+ mkdir -p ${bindir}
-+ $(INSTALL) -g root -m $(BINMODE) -o root ${srcdir}/$(PROGRAM) ${bindir}
- @echo "Installing man page..."
-+ mkdir -p ${mandir}
- @$(SEDBIN) $(SEDCMDS) ${docdir}/iso3166.1.in > ${mandir}/iso3166.1
- @chown 0.0 ${mandir}/iso3166.1
- @echo
diff --git a/app-misc/countrycodes/files/1.0.6-Makefile.patch b/app-misc/countrycodes/files/1.0.6-Makefile.patch
new file mode 100644
index 000000000000..051c02946230
--- /dev/null
+++ b/app-misc/countrycodes/files/1.0.6-Makefile.patch
@@ -0,0 +1,35 @@
+diff --git a/Makefile b/Makefile
+index b6e1323..b11a453 100644
+--- a/Makefile
++++ b/Makefile
+@@ -23,10 +23,9 @@ BINMODE=755
+ LOGDIRMODE=700
+
+ # Compiler to use
+-CC=gcc
+
+ # Compiler warnings
+-WARNINGS= -pedantic -Wall
++CFLAGS += -pedantic -Wall
+
+ # Compiler flags
+ CCOPTS = -O2 -fomit-frame-pointer
+@@ -58,7 +57,7 @@ PROGRAM = iso3166
+ all: $(PROGRAM)
+
+ $(PROGRAM): $(ISO3166OBJ)
+- $(CC) $(CCOPTS) $(ISO3166OBJ) -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) $(ISO3166OBJ) -o $@
+
+ clean:
+ $(RM) $(ISO3166OBJ) core defines.h $(PROGRAM)
+@@ -79,9 +78,6 @@ uninstall:
+ $(RM) ${bindir}/$(PROGRAM)
+ $(RM) ${mandir}/iso3166.1
+
+-.c.o:
+- $(CC) $(CCOPTS) $(WARNINGS) -c $<
+-
+ $(ISO3166OBJ): common.h defines.h protos.h tables.h
+
+ defines.h: