summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/countrycodes')
-rw-r--r--app-misc/countrycodes/Manifest2
-rw-r--r--app-misc/countrycodes/countrycodes-1.0.5-r3.ebuild32
-rw-r--r--app-misc/countrycodes/countrycodes-1.0.6.ebuild29
-rw-r--r--app-misc/countrycodes/files/1.0.5-Makefile.patch42
-rw-r--r--app-misc/countrycodes/files/1.0.6-Makefile.patch35
-rw-r--r--app-misc/countrycodes/metadata.xml5
6 files changed, 69 insertions, 76 deletions
diff --git a/app-misc/countrycodes/Manifest b/app-misc/countrycodes/Manifest
index aeb223a8e905..81eb311e7c37 100644
--- a/app-misc/countrycodes/Manifest
+++ b/app-misc/countrycodes/Manifest
@@ -1 +1 @@
-DIST countrycodes-1.0.5.tar.gz 18621 BLAKE2B 1f2e1fb0f96d1388687929895c310e1e93c320f4d3f3f4cfe19c50d2ab850bafcefb5e13cfdaed546237ae5873eb95ae574ac47c0048bc2fa37c96158b5082fe SHA512 d62beaaccdbc8f7e14f3edf0044aeeef6375a3deffc0e4246a49fb8209ed7256208c878f811950c5c3bfda729988a46c173aecec72ee66e8843932d97064f035
+DIST countrycodes-1.0.6.tar.gz 18834 BLAKE2B b5e0806618da0dd740a890b9c4d369cf2c44182515ec91aaa08a5e19da447635fb8536611a278ffcc419b506efa07df7e71bf5d520895a059c4aaa6e0cbc9b48 SHA512 be069593f60f785ef4d2e107340b941902a9c45d81ed04f8518a78f2be610ffdd1675da3da1d07271fc7ab736aabdd9f92f060d132e7b7b41310f1b653c53244
diff --git a/app-misc/countrycodes/countrycodes-1.0.5-r3.ebuild b/app-misc/countrycodes/countrycodes-1.0.5-r3.ebuild
deleted file mode 100644
index 1860a7e686ea..000000000000
--- a/app-misc/countrycodes/countrycodes-1.0.5-r3.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-DESCRIPTION="An ISO 3166 country code finder"
-HOMEPAGE="http://www.grigna.com/diego/linux/countrycodes/"
-SRC_URI="http://www.grigna.com/diego/linux/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ~ia64 ~mips ppc ppc64 ~sparc x86"
-
-S="${WORKDIR}"/${P}/src
-
-PATCHES=( "${FILESDIR}/${PV}-Makefile.patch" )
-
-src_prepare() {
- default
- tc-export CC
-}
-
-src_install() {
- emake \
- prefix="${D}/usr" \
- mandir="${D}/usr/share/man/man1" install
- dosym iso3166 /usr/bin/countrycodes
- dosym iso3166.1 /usr/share/man/man1/countrycodes
- dodoc ../doc/{Changelog,README}
-}
diff --git a/app-misc/countrycodes/countrycodes-1.0.6.ebuild b/app-misc/countrycodes/countrycodes-1.0.6.ebuild
new file mode 100644
index 000000000000..e0696c3467c7
--- /dev/null
+++ b/app-misc/countrycodes/countrycodes-1.0.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="An ISO 3166 country code finder"
+HOMEPAGE="https://sourceforge.net/projects/countrycodes/"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ia64 ~mips ppc ppc64 ~sparc x86"
+
+PATCHES=( "${FILESDIR}"/${PV}-Makefile.patch )
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ emake \
+ prefix="${ED}"/usr \
+ mandir="${ED}"/usr/share/man install
+ dosym iso3166 /usr/bin/countrycodes
+ dosym iso3166.1 /usr/share/man/man1/countrycodes
+ dodoc README
+}
diff --git a/app-misc/countrycodes/files/1.0.5-Makefile.patch b/app-misc/countrycodes/files/1.0.5-Makefile.patch
deleted file mode 100644
index 677e59acc5c0..000000000000
--- a/app-misc/countrycodes/files/1.0.5-Makefile.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 9330578..3ff7319 100644
---- a/Makefile
-+++ b/Makefile
-@@ -26,13 +26,13 @@ BINMODE=755
- LOGDIRMODE=700
-
- # Compiler to use
--CC=gcc
-+CC ?= gcc
-
- # Compiler warnings
--WARNINGS= -pedantic -Wall
-+WARNINGS=
-
- # Compiler flags
--CCOPTS = -O2 -fomit-frame-pointer
-+CCOPTS = ${CFLAGS}
-
- # The makefile standards document I read says that I have to put it here...
- SHELL = /bin/sh
-@@ -61,7 +61,7 @@ PROGRAM = iso3166
- all: $(PROGRAM)
-
- $(PROGRAM): $(ISO3166OBJ)
-- $(CC) $(CCOPTS) $(ISO3166OBJ) -o $@
-+ $(CC) $(CCOPTS) $(LDFLAGS) $(ISO3166OBJ) -o $@
-
- clean:
- rm -f $(ISO3166OBJ) core defines.h $(PROGRAM)
-@@ -70,8 +70,10 @@ strip:
- strip $(PROGRAM)
-
- install:
-- $(INSTALL) -g root -m $(BINMODE) -o root -s ${srcdir}/$(PROGRAM) ${bindir}
-+ mkdir -p ${bindir}
-+ $(INSTALL) -g root -m $(BINMODE) -o root ${srcdir}/$(PROGRAM) ${bindir}
- @echo "Installing man page..."
-+ mkdir -p ${mandir}
- @$(SEDBIN) $(SEDCMDS) ${docdir}/iso3166.1.in > ${mandir}/iso3166.1
- @chown 0.0 ${mandir}/iso3166.1
- @echo
diff --git a/app-misc/countrycodes/files/1.0.6-Makefile.patch b/app-misc/countrycodes/files/1.0.6-Makefile.patch
new file mode 100644
index 000000000000..051c02946230
--- /dev/null
+++ b/app-misc/countrycodes/files/1.0.6-Makefile.patch
@@ -0,0 +1,35 @@
+diff --git a/Makefile b/Makefile
+index b6e1323..b11a453 100644
+--- a/Makefile
++++ b/Makefile
+@@ -23,10 +23,9 @@ BINMODE=755
+ LOGDIRMODE=700
+
+ # Compiler to use
+-CC=gcc
+
+ # Compiler warnings
+-WARNINGS= -pedantic -Wall
++CFLAGS += -pedantic -Wall
+
+ # Compiler flags
+ CCOPTS = -O2 -fomit-frame-pointer
+@@ -58,7 +57,7 @@ PROGRAM = iso3166
+ all: $(PROGRAM)
+
+ $(PROGRAM): $(ISO3166OBJ)
+- $(CC) $(CCOPTS) $(ISO3166OBJ) -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) $(ISO3166OBJ) -o $@
+
+ clean:
+ $(RM) $(ISO3166OBJ) core defines.h $(PROGRAM)
+@@ -79,9 +78,6 @@ uninstall:
+ $(RM) ${bindir}/$(PROGRAM)
+ $(RM) ${mandir}/iso3166.1
+
+-.c.o:
+- $(CC) $(CCOPTS) $(WARNINGS) -c $<
+-
+ $(ISO3166OBJ): common.h defines.h protos.h tables.h
+
+ defines.h:
diff --git a/app-misc/countrycodes/metadata.xml b/app-misc/countrycodes/metadata.xml
index 3cf14bf74636..3755461f1aa3 100644
--- a/app-misc/countrycodes/metadata.xml
+++ b/app-misc/countrycodes/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>shell-tools@gentoo.org</email>
<name>Gentoo Shell Tools Project</name>
</maintainer>
+ <upstream>
+ <remote-id type="sourceforge">countrycodes</remote-id>
+ </upstream>
</pkgmetadata>