summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/cpipe/cpipe-3.0.3-r1.ebuild')
-rw-r--r--app-misc/cpipe/cpipe-3.0.3-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-misc/cpipe/cpipe-3.0.3-r1.ebuild b/app-misc/cpipe/cpipe-3.0.3-r1.ebuild
new file mode 100644
index 000000000000..e1798e5b3092
--- /dev/null
+++ b/app-misc/cpipe/cpipe-3.0.3-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Counting pipe, measures data transfered over pipe"
+HOMEPAGE="https://github.com/HaraldKi/cpipe"
+SRC_URI="https://github.com/HaraldKi/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin cpipe
+
+ einstalldocs
+ doman cpipe.1
+}