summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/dasel')
-rw-r--r--app-misc/dasel/Manifest4
-rw-r--r--app-misc/dasel/dasel-1.27.3.ebuild24
-rw-r--r--app-misc/dasel/dasel-2.7.0.ebuild24
-rw-r--r--app-misc/dasel/metadata.xml11
4 files changed, 63 insertions, 0 deletions
diff --git a/app-misc/dasel/Manifest b/app-misc/dasel/Manifest
new file mode 100644
index 000000000000..200d99bd1ed8
--- /dev/null
+++ b/app-misc/dasel/Manifest
@@ -0,0 +1,4 @@
+DIST dasel-1.24.3-deps.tar.xz 20531068 BLAKE2B 6cd947a88c54e46300432c2f87c0ef757a53739e0755af48f4596a87ba46faf12c967145a0f263e13abb8f01ffe10c51b45f641de348fc02e7af39417b709d1d SHA512 27696cd5a5c93b3e29ba12fd2730c04047dc752ef17a32db73e7cbc8e5d38d914705720da9ff0ffb0c8d3fb383b5070eb552b24a4e72e72ebad70c2e1085cab3
+DIST dasel-1.27.3.tar.gz 3056021 BLAKE2B 2145f501f837cd16aaa7cc16074e446e07cbb8b6b7ce043c644badbe758d255c9e42f408ca818e6241feb91f22eaa1e8e7fbf74b84275b7eba576687e877b1aa SHA512 51e5f770f75e34f72692adf0987bcb965dd2100ac3e251c035cf62479462e22f982640bab6adac3c12bebac6987f7852f53cceb2c0c4d6dd009befe843cc1aec
+DIST dasel-2.7.0-deps.tar.xz 1219584 BLAKE2B 91cfc1225588ba397d9dc5b62297876164644c08260288d09fb843cf7c8619909c11126f54e5c1be1a225a55e3f60184bbdad6ed5e86dafe27c2892eb646066f SHA512 d2f6545ddb3f62acaa0b98894321f53e01e8fefbc0c8e4327e051dd513fa3a47bbc822ffb7b856a3897915962cfac01d080adc7778d9349ff3282d1cce1debeb
+DIST dasel-2.7.0.tar.gz 2793422 BLAKE2B 27fdc70f998c389453c7b6c6ec59491f3482ff7df1a043499e985179c5a51f6b58328272d733eddb28009ada0dd206b0e4fed37ec6bc43229314a0c1906e215e SHA512 37753bc124511bc2105186ad62090bda25e8574b5c1ec2cc2583f91e9f8ab41de261f870600ea1a501f41c5ad3b13999c64ca995eee50ee120359f819f6f334a
diff --git a/app-misc/dasel/dasel-1.27.3.ebuild b/app-misc/dasel/dasel-1.27.3.ebuild
new file mode 100644
index 000000000000..261c64912713
--- /dev/null
+++ b/app-misc/dasel/dasel-1.27.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module
+
+DESCRIPTION="Query, update and convert data structures from the command line"
+HOMEPAGE="https://github.com/TomWright/dasel"
+SRC_URI="https://github.com/TomWright/dasel/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~zmedico/dist/dasel-1.24.3-deps.tar.xz"
+
+LICENSE="MIT Apache-2.0 BSD BSD-2 ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+src_compile() {
+ CGO_ENABLED=0 go build -o bin/dasel -ldflags="-X 'github.com/tomwright/dasel/internal.Version=${PV}'" ./cmd/dasel || die
+}
+
+src_install() {
+ dobin bin/dasel
+ dodoc CHANGELOG.md README.md
+}
diff --git a/app-misc/dasel/dasel-2.7.0.ebuild b/app-misc/dasel/dasel-2.7.0.ebuild
new file mode 100644
index 000000000000..ebf04bd39740
--- /dev/null
+++ b/app-misc/dasel/dasel-2.7.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="Query, update and convert data structures from the command line"
+HOMEPAGE="https://github.com/TomWright/dasel"
+SRC_URI="https://github.com/TomWright/dasel/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~zmedico/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT Apache-2.0 BSD BSD-2 ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+src_compile() {
+ CGO_ENABLED=0 go build -o bin/dasel -ldflags="-X 'github.com/tomwright/dasel/internal.Version=${PV}'" ./cmd/dasel || die
+}
+
+src_install() {
+ dobin bin/dasel
+ dodoc CHANGELOG.md README.md
+}
diff --git a/app-misc/dasel/metadata.xml b/app-misc/dasel/metadata.xml
new file mode 100644
index 000000000000..b08ff3cac9af
--- /dev/null
+++ b/app-misc/dasel/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ <name>Zac Medico</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">TomWright/dasel</remote-id>
+ </upstream>
+</pkgmetadata>