summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/datefudge/datefudge-1.17.ebuild')
-rw-r--r--app-misc/datefudge/datefudge-1.17.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-misc/datefudge/datefudge-1.17.ebuild b/app-misc/datefudge/datefudge-1.17.ebuild
new file mode 100644
index 000000000000..67db96de6427
--- /dev/null
+++ b/app-misc/datefudge/datefudge-1.17.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit multilib toolchain-funcs eutils
+
+DESCRIPTION="A program (and preload library) to fake system date"
+HOMEPAGE="http://packages.qa.debian.org/d/datefudge.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+src_prepare() {
+ use userland_BSD && epatch "${FILESDIR}"/${P}-bsd.patch
+ sed -i \
+ -e '/dpkg-parsechangelog/d' \
+ -e "s:usr/lib:usr/$(get_libdir):" \
+ Makefile || die
+
+ if use prefix; then
+ sed -i -e '/-o root -g root/d' Makefile || die
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" VERSION="${PV}"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" VERSION="${PV}" install
+ dodoc debian/changelog README
+}