summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/datefudge/datefudge-1.24.ebuild')
-rw-r--r--app-misc/datefudge/datefudge-1.24.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-misc/datefudge/datefudge-1.24.ebuild b/app-misc/datefudge/datefudge-1.24.ebuild
new file mode 100644
index 000000000000..1209277f28ae
--- /dev/null
+++ b/app-misc/datefudge/datefudge-1.24.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="A program (and preload library) to fake system date"
+HOMEPAGE="https://packages.qa.debian.org/d/datefudge.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/dpkg-parsechangelog/d' \
+ Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" libdir="/usr/$(get_libdir)" VERSION="${PV}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" CC="$(tc-getCC)" libdir="/usr/$(get_libdir)" install
+ einstalldocs
+}