summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/ddccontrol-db/ddccontrol-db-20210812.ebuild')
-rw-r--r--app-misc/ddccontrol-db/ddccontrol-db-20210812.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-misc/ddccontrol-db/ddccontrol-db-20210812.ebuild b/app-misc/ddccontrol-db/ddccontrol-db-20210812.ebuild
new file mode 100644
index 000000000000..7ab5fbdc3d16
--- /dev/null
+++ b/app-misc/ddccontrol-db/ddccontrol-db-20210812.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="DDCControl monitor database"
+HOMEPAGE="http://ddccontrol.sourceforge.net/"
+SRC_URI="https://github.com/ddccontrol/ddccontrol-db/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-perl/XML-Parser"
+
+src_prepare() {
+ touch db/options.xml.h ABOUT-NLS config.rpath || die
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README.md
+}