summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/ddccontrol-db')
-rw-r--r--app-misc/ddccontrol-db/Manifest3
-rw-r--r--app-misc/ddccontrol-db/ddccontrol-db-20190826_p20200613.ebuild39
-rw-r--r--app-misc/ddccontrol-db/ddccontrol-db-20230223.ebuild30
-rw-r--r--app-misc/ddccontrol-db/ddccontrol-db-20230627.ebuild30
-rw-r--r--app-misc/ddccontrol-db/metadata.xml3
5 files changed, 63 insertions, 42 deletions
diff --git a/app-misc/ddccontrol-db/Manifest b/app-misc/ddccontrol-db/Manifest
index ac37a45d0809..f671fc666ed1 100644
--- a/app-misc/ddccontrol-db/Manifest
+++ b/app-misc/ddccontrol-db/Manifest
@@ -1 +1,2 @@
-DIST ddccontrol-db-20190826_p20200613.tar.gz 85044 BLAKE2B 6f80a7a53843dc29ff6158614dd36eba3d7f8172e21592776426464729b4bdcfd3bea51b8412919aa5231015f75766da51eb71f4d808b4c280c045209a4edf1a SHA512 9171193fd31c877699df9e8740cbed0a8de68acc41b614ded36022a25be27f01cf34129033ae3c219211bff54ea82882a955f587dfa87fa7571d3992ac3fa4de
+DIST ddccontrol-db-20230223.tar.gz 112436 BLAKE2B 2ea33abe318005b340481ea6973ecbf5e261dfdd5579ad016262d0e1ee5ef44e15d16600a88d0323810bed4bf062632406c305202296932dc2e71288a888b091 SHA512 303345137d9f5760d4ee10db75322a3be97fe4269eb469e4ff798fe69f60670b8408ca87d2b3ad10f47ccb1f33c99c3ce09a1294f60e66d429074df685ab1501
+DIST ddccontrol-db-20230627.tar.gz 118149 BLAKE2B addbe499c4021efd3114740100abc3bdbb0bbeb5519a77340e90f736e72d1ffe80996bdfe450e60a6bba78175ddf9fb2be162e399402ed306dbdd931f1760a4e SHA512 efb1f1d407705e5baa3bc8924af4f7edb1ad05c36af5301a4d3053fa5aca4739d72091f00da4ec10ad0511ee1bfd148e75db66fd1c1a1e50e97d51679aa6ae64
diff --git a/app-misc/ddccontrol-db/ddccontrol-db-20190826_p20200613.ebuild b/app-misc/ddccontrol-db/ddccontrol-db-20190826_p20200613.ebuild
deleted file mode 100644
index f230ee9f2591..000000000000
--- a/app-misc/ddccontrol-db/ddccontrol-db-20190826_p20200613.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools
-
-DESCRIPTION="DDCControl monitor database"
-HOMEPAGE="http://ddccontrol.sourceforge.net/"
-COMMIT_ID="e75714979448b2f513d5ce65929899fa32a59044"
-MY_PV=${COMMIT_ID:-${PV}}
-SRC_URI="https://github.com/ddccontrol/ddccontrol-db/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="nls"
-
-S=${WORKDIR}/${PN}-${MY_PV}
-
-RDEPEND="nls? ( sys-devel/gettext )"
-DEPEND="${RDEPEND}
- dev-util/intltool
- dev-perl/XML-Parser"
-
-src_prepare() {
- touch db/options.xml.h ABOUT-NLS config.rpath || die
- eapply_user
- eautoreconf
-}
-
-src_configure() {
- econf $(use_enable nls)
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS ChangeLog NEWS README.md
-}
diff --git a/app-misc/ddccontrol-db/ddccontrol-db-20230223.ebuild b/app-misc/ddccontrol-db/ddccontrol-db-20230223.ebuild
new file mode 100644
index 000000000000..c702318cfafa
--- /dev/null
+++ b/app-misc/ddccontrol-db/ddccontrol-db-20230223.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="DDCControl monitor database"
+HOMEPAGE="https://github.com/ddccontrol/ddccontrol-db"
+SRC_URI="https://github.com/ddccontrol/ddccontrol-db/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+BDEPEND="
+ dev-util/intltool
+ dev-perl/XML-Parser
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ touch db/options.xml.h ABOUT-NLS config.rpath || die
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
diff --git a/app-misc/ddccontrol-db/ddccontrol-db-20230627.ebuild b/app-misc/ddccontrol-db/ddccontrol-db-20230627.ebuild
new file mode 100644
index 000000000000..c702318cfafa
--- /dev/null
+++ b/app-misc/ddccontrol-db/ddccontrol-db-20230627.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="DDCControl monitor database"
+HOMEPAGE="https://github.com/ddccontrol/ddccontrol-db"
+SRC_URI="https://github.com/ddccontrol/ddccontrol-db/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+BDEPEND="
+ dev-util/intltool
+ dev-perl/XML-Parser
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ touch db/options.xml.h ABOUT-NLS config.rpath || die
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
diff --git a/app-misc/ddccontrol-db/metadata.xml b/app-misc/ddccontrol-db/metadata.xml
index c4fc6138be3c..36c44e266b2f 100644
--- a/app-misc/ddccontrol-db/metadata.xml
+++ b/app-misc/ddccontrol-db/metadata.xml
@@ -1,9 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
<upstream>
<remote-id type="github">ddccontrol/ddccontrol-db</remote-id>
- <remote-id type="sourceforge">ddccontrol</remote-id>
</upstream>
</pkgmetadata>