summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/esekeyd/esekeyd-1.2.7-r2.ebuild')
-rw-r--r--app-misc/esekeyd/esekeyd-1.2.7-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-misc/esekeyd/esekeyd-1.2.7-r2.ebuild b/app-misc/esekeyd/esekeyd-1.2.7-r2.ebuild
new file mode 100644
index 000000000000..4ba1d3e5b7b5
--- /dev/null
+++ b/app-misc/esekeyd/esekeyd-1.2.7-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Multimedia key daemon that uses the Linux event interface"
+HOMEPAGE="https://github.com/burghardt/esekeyd"
+SRC_URI="https://github.com/burghardt/esekeyd/archive/refs/tags/${P}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc x86"
+
+PATCHES=(
+ "${FILESDIR}/1.2.7-fix-revision.patch"
+)
+
+DOCS=( AUTHORS ChangeLog examples/example.conf NEWS README TODO )
+
+src_prepare() {
+ default
+ eautoreconf
+}