summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/faq/faq-0.0.7.ebuild')
-rw-r--r--app-misc/faq/faq-0.0.7.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-misc/faq/faq-0.0.7.ebuild b/app-misc/faq/faq-0.0.7.ebuild
new file mode 100644
index 000000000000..1948dcc1b163
--- /dev/null
+++ b/app-misc/faq/faq-0.0.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Format agnostic jQ"
+HOMEPAGE="https://github.com/jzelinskie/faq"
+SRC_URI="https://github.com/jzelinskie/faq/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="app-misc/jq
+ dev-libs/oniguruma:="
+
+DOCS=( README.md docs/examples.md )
+
+QA_FLAGS_IGNORED="usr/bin/faq"
+QA_PRESTRIPPED="usr/bin/faq"
+
+src_compile() {
+ emake FAQ_VERSION="${PV}" build
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}" bindir="/usr/bin" install
+
+ einstalldocs
+}