summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/fdupes/fdupes-1.6.1-r1.ebuild')
-rw-r--r--app-misc/fdupes/fdupes-1.6.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/fdupes/fdupes-1.6.1-r1.ebuild b/app-misc/fdupes/fdupes-1.6.1-r1.ebuild
new file mode 100644
index 000000000000..b127dfcbd858
--- /dev/null
+++ b/app-misc/fdupes/fdupes-1.6.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Identify/delete duplicate files residing within specified directories"
+HOMEPAGE="https://github.com/adrianlopezroche/fdupes"
+SRC_URI="https://github.com/adrianlopezroche/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+src_prepare() {
+ default
+ append-lfs-flags
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+ einstalldocs
+}