summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/fhem')
-rw-r--r--app-misc/fhem/Manifest2
-rw-r--r--app-misc/fhem/fhem-5.9.ebuild104
-rw-r--r--app-misc/fhem/fhem-6.2.ebuild (renamed from app-misc/fhem/fhem-5.9-r1.ebuild)16
-rw-r--r--app-misc/fhem/files/fhem.service-r1 (renamed from app-misc/fhem/files/fhem.service)5
-rw-r--r--app-misc/fhem/metadata.xml8
5 files changed, 16 insertions, 119 deletions
diff --git a/app-misc/fhem/Manifest b/app-misc/fhem/Manifest
index b200f36cc24c..05fe0c680ff2 100644
--- a/app-misc/fhem/Manifest
+++ b/app-misc/fhem/Manifest
@@ -1 +1 @@
-DIST fhem-5.9.tar.gz 23267499 BLAKE2B c2c2e4ab21f82fbe67c9e99aed4d1edd6db889aedac0611b5ba2873667520c4aa63d8553e014563f6f6ee58c5792ae1735853f58c8f4ef0599583b2ed23a9efe SHA512 9f75058e698fc33ec64081695db3eb2511f686dedc3107c87d4377f655c8b204892c6f61141de28970f2ed3f8cef5d24124d17ee20ee71a9eb9318bb17335bb8
+DIST fhem-6.2.tar.gz 32526944 BLAKE2B 00ec9cb1518ab002e0565150a30ec7191c1f0a8ae0fccb7a3a745837f7794e4f61a8e7fa4707416e841f86803d69c27f7158c36f765733e76f461dcbb15e306e SHA512 8bb4cf277ab3f008b353c3fa7f67a50f502299e79f2b96d13e88150766e39498888a05a44b6509a51f90d82dcd0aefa6642deea585c72d65e3849b6aa0322143
diff --git a/app-misc/fhem/fhem-5.9.ebuild b/app-misc/fhem/fhem-5.9.ebuild
deleted file mode 100644
index e84340e0b59c..000000000000
--- a/app-misc/fhem/fhem-5.9.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit systemd user
-
-DESCRIPTION="A GPL'd perl server for house automation"
-HOMEPAGE="https://www.fhem.de/"
-SRC_URI="https://www.fhem.de/${P}.tar.gz"
-
-KEYWORDS="amd64 x86"
-LICENSE="GPL-2+"
-SLOT="0"
-IUSE="doc"
-
-RDEPEND="dev-perl/Crypt-CBC
- dev-perl/Device-SerialPort
- dev-perl/Digest-CRC
- dev-perl/JSON"
-
-DEPEND="media-gfx/pngcrush"
-
-pkg_setup() {
- enewgroup fhem
- enewuser fhem -1 -1 /opt/fhem fhem
-}
-
-src_prepare() {
- default
-
- # Allow install path to be set by DESTDIR in Makefile
- sed -i -e 's,^\(BINDIR=\),\1'\$\(DESTDIR\)',' Makefile || die
-
- # Remove docs in Makefile, as they will be installed manually
- sed -i -e 's/docs//g' Makefile || die
- sed -i -e '/README_DEMO.txt/d' Makefile || die
-
- # Remove manpage in Makefile, as it will be installed manually
- sed -i -e '/fhem.pl.1/d' Makefile || die
-
- # Remove lcd4linux binaries, as they are provied by app-misc/lcd4linux
- rm -r contrib/lcd4linux || die
-
- # Remove log dir, as it will be replaced with a symlink
- rm -r log || die
-
- # Fix fhemicon_darksmall.png, as it reports "broken IDAT window length"
- # Reported to Upstream: https://forum.fhem.de/index.php/topic,86238.0.html
- pngcrush -fix -force -ow www/images/default/fhemicon_darksmall.png || die
-
- cp "${FILESDIR}"/fhem.cfg fhem.cfg || die
-}
-
-src_compile() {
- :
-}
-
-src_install() {
- local DOCS=(
- "CHANGED"
- "HISTORY"
- "MAINTAINER.txt"
- "README.SVN"
- "README_DEMO.txt"
- "docs"/*.txt
- "docs"/*.patch
- "docs"/*.pdf
- "docs/changelog"
- "docs/copyright"
- "docs/dotconfig"
- "docs/fhem.odg.readme"
- "docs/LIESMICH.update-thirdparty"
- "docs"/README*
- "docs/X10"
- )
-
- if use doc; then
- local DOCS+=( "docs/X10" )
- local HTML_DOCS=( "docs/"*.eps "docs/"*.html "docs"/*.jpg "docs"/*.js "docs"/*.odg "docs/"*.png "docs/km271" )
- fi
-
- diropts -o fhem -g fhem
- keepdir "/var/lib/fhem"
- keepdir "/var/log/fhem"
- diropts
-
- dosym ../../var/lib/fhem /opt/fhem/data
- dosym ../../var/log/fhem /opt/fhem/log
-
- default
-
- newinitd "${FILESDIR}"/fhem.initd fhem
-
- systemd_dounit "${FILESDIR}"/fhem.service
- systemd_newtmpfilesd "${FILESDIR}"/fhem.tmpfiles fhem.conf
-
- newman docs/fhem.man fhem.pl.1
-
- echo 'CONFIG_PROTECT="/opt/fhem /var/lib/fhem"' > "${T}"/99fhem || die
- doenvd "${T}"/99fhem
-
- fowners fhem:fhem /opt/fhem/fhem.cfg
-}
diff --git a/app-misc/fhem/fhem-5.9-r1.ebuild b/app-misc/fhem/fhem-6.2.ebuild
index 7d804c1d86e6..154939f05f50 100644
--- a/app-misc/fhem/fhem-5.9-r1.ebuild
+++ b/app-misc/fhem/fhem-6.2.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit systemd
+inherit systemd tmpfiles
DESCRIPTION="A GPL'd perl server for house automation"
HOMEPAGE="https://www.fhem.de/"
SRC_URI="https://www.fhem.de/${P}.tar.gz"
-KEYWORDS="~amd64 ~x86"
LICENSE="GPL-2+"
SLOT="0"
+KEYWORDS="amd64 x86"
IUSE="doc"
RDEPEND="
@@ -91,8 +91,8 @@ src_install() {
newinitd "${FILESDIR}"/fhem.initd fhem
- systemd_dounit "${FILESDIR}"/fhem.service
- systemd_newtmpfilesd "${FILESDIR}"/fhem.tmpfiles fhem.conf
+ systemd_newunit "${FILESDIR}"/fhem.service-r1 fhem.service
+ newtmpfiles "${FILESDIR}"/fhem.tmpfiles fhem.conf
newman docs/fhem.man fhem.pl.1
@@ -101,3 +101,7 @@ src_install() {
fowners fhem:fhem /opt/fhem/fhem.cfg
}
+
+pkg_postinst() {
+ tmpfiles_process fhem.conf
+}
diff --git a/app-misc/fhem/files/fhem.service b/app-misc/fhem/files/fhem.service-r1
index 697a10179d40..aaf48fc88c4e 100644
--- a/app-misc/fhem/files/fhem.service
+++ b/app-misc/fhem/files/fhem.service-r1
@@ -1,13 +1,14 @@
[Unit]
-Description=FHEM
+Description=FHEM Home Automation
After=network-online.target
[Service]
-Type=simple
+Type=forking
User=fhem
Group=fhem
WorkingDirectory=/opt/fhem
ExecStart=/opt/fhem/fhem.pl /opt/fhem/fhem.cfg
+Restart=always
[Install]
WantedBy=multi-user.target
diff --git a/app-misc/fhem/metadata.xml b/app-misc/fhem/metadata.xml
index 92b432980845..6801bef65ba4 100644
--- a/app-misc/fhem/metadata.xml
+++ b/app-misc/fhem/metadata.xml
@@ -1,14 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>ck+gentoo@bl4ckb0x.de</email>
+ <email>conikost@gentoo.org</email>
<name>Conrad Kostecki</name>
</maintainer>
- <maintainer type="project">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
<longdescription>
FHEM is a GPL'd perl server for house automation.
It is used to automate some common tasks in the household like