summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/filebus/filebus-0.3.5.ebuild')
-rw-r--r--app-misc/filebus/filebus-0.3.5.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/app-misc/filebus/filebus-0.3.5.ebuild b/app-misc/filebus/filebus-0.3.5.ebuild
index b79175ae49cb..71ab1c8994b0 100644
--- a/app-misc/filebus/filebus-0.3.5.ebuild
+++ b/app-misc/filebus/filebus-0.3.5.ebuild
@@ -1,15 +1,15 @@
-# Copyright 2021-2022 Gentoo Authors
+# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python3_{7,8,9,10} )
+PYTHON_COMPAT=( python3_{10,11,12} )
+DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1
+inherit distutils-r1 pypi
DESCRIPTION="A user space multicast named pipe implementation backed by a regular file"
HOMEPAGE="https://github.com/pipebus/filebus"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
KEYWORDS="~amd64"
@@ -24,7 +24,7 @@ RDEPEND="
dev-python/filelock[${PYTHON_USEDEP}]
inotify? ( dev-python/watchdog[${PYTHON_USEDEP}] )
)"
-BDEPEND="${RDEPEND}"
+BDEPEND="${DISTUTILS_DEPS} ${RDEPEND}"
src_prepare() {
default