summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/fmawk')
-rw-r--r--app-misc/fmawk/Manifest1
-rw-r--r--app-misc/fmawk/fmawk-1.3.ebuild38
-rw-r--r--app-misc/fmawk/fmawk-9999.ebuild38
-rw-r--r--app-misc/fmawk/metadata.xml19
4 files changed, 96 insertions, 0 deletions
diff --git a/app-misc/fmawk/Manifest b/app-misc/fmawk/Manifest
new file mode 100644
index 000000000000..e07314a8e2e5
--- /dev/null
+++ b/app-misc/fmawk/Manifest
@@ -0,0 +1 @@
+DIST fmawk-1.3.tar.gz 25628 BLAKE2B e9b591941c5dbfa96414cc494b91eebfc19e9153cad7066afe216a6e1a177de5c3f3e04f09fec62bbd0adf0b3330bfc9471fcecc23b568e966e8185b7a298c39 SHA512 b1ca40c71b219cd59009c96692e1297cec75d2a61b28c330e4b80b55bde6dc6dfb071fec9dc4ae4f3e8aa7be7bbb51d444687f9500c82dba440388d41369e157
diff --git a/app-misc/fmawk/fmawk-1.3.ebuild b/app-misc/fmawk/fmawk-1.3.ebuild
new file mode 100644
index 000000000000..1401e88a7e30
--- /dev/null
+++ b/app-misc/fmawk/fmawk-1.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="File manager written in awk"
+HOMEPAGE="https://github.com/huijunchen9260/fm.awk/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/huijunchen9260/fm.awk.git"
+else
+ SRC_URI="https://github.com/huijunchen9260/fm.awk/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/fm.awk-${PV}"
+ KEYWORDS="amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="app-alternatives/awk"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ optfeature "PDFs preview" app-text/poppler
+ optfeature "images preview" media-gfx/chafa
+ optfeature "videos preview" media-video/ffmpegthumbnailer
+}
diff --git a/app-misc/fmawk/fmawk-9999.ebuild b/app-misc/fmawk/fmawk-9999.ebuild
new file mode 100644
index 000000000000..57d3dbc7f79e
--- /dev/null
+++ b/app-misc/fmawk/fmawk-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="File manager written in awk"
+HOMEPAGE="https://github.com/huijunchen9260/fm.awk/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/huijunchen9260/fm.awk.git"
+else
+ SRC_URI="https://github.com/huijunchen9260/fm.awk/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/fm.awk-${PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="app-alternatives/awk"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ optfeature "PDFs preview" app-text/poppler
+ optfeature "images preview" media-gfx/chafa
+ optfeature "videos preview" media-video/ffmpegthumbnailer
+}
diff --git a/app-misc/fmawk/metadata.xml b/app-misc/fmawk/metadata.xml
new file mode 100644
index 000000000000..210d6b4a9b9a
--- /dev/null
+++ b/app-misc/fmawk/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ FMAWK is a experimental file manager written almost entirely in the awk
+ programming language. Though written in awk, in terms of features it is
+ comparable to other terminal file managers such as fff, nnn or ranger.
+ </longdescription>
+ <upstream>
+ <changelog>https://github.com/huijunchen9260/fm.awk/releases/</changelog>
+ <bugs-to>https://github.com/huijunchen9260/fm.awk/issues</bugs-to>
+ <remote-id type="github">huijunchen9260/fm.awk</remote-id>
+ </upstream>
+</pkgmetadata>