summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/fr24feed')
-rw-r--r--app-misc/fr24feed/Manifest2
-rw-r--r--app-misc/fr24feed/files/fr24feed.confd5
-rw-r--r--app-misc/fr24feed/files/fr24feed.ini2
-rw-r--r--app-misc/fr24feed/files/fr24feed.initd25
-rw-r--r--app-misc/fr24feed/fr24feed-1.0.46_p2.ebuild40
-rw-r--r--app-misc/fr24feed/metadata.xml20
6 files changed, 94 insertions, 0 deletions
diff --git a/app-misc/fr24feed/Manifest b/app-misc/fr24feed/Manifest
new file mode 100644
index 000000000000..dc1eb11cae47
--- /dev/null
+++ b/app-misc/fr24feed/Manifest
@@ -0,0 +1,2 @@
+DIST fr24feed_1.0.46-2_amd64.tgz 5481020 BLAKE2B b2e4b0b53b62a7056fda3868a35358d943cb31cdf988cab94d0bf9df67fd83d7db4ffedcb6582e90a062d18885f6cc8a5c8a680e530f7f1fc0c91fd49c6db265 SHA512 83d22375f9e294a8ad862b01b3e093908cecb5a7751ab9ad3c5c0b7dadae7a1007544c373a78f39e14a5cbc1c10e18157a8ef81844695a17b21e3836eb9b2bb7
+DIST fr24feed_1.0.46-2_i386.tgz 5322012 BLAKE2B 2bea3c93bcfcf6c23904b9a283f7e3dc43f564173a9dd9063858d3070548de67868fe4adf8bea3e505279c2dd1c9936fa1f9d60da14ea5b8a59b611432299fdb SHA512 67a3771e3b9ff4f75491a1b99e03f0942418d87d9b30ac650a4f33fae116547133c95d37f4384832bf59a16d01b506cebc3227f4bbc7c08da800510d1ea02bca
diff --git a/app-misc/fr24feed/files/fr24feed.confd b/app-misc/fr24feed/files/fr24feed.confd
new file mode 100644
index 000000000000..90288849bf59
--- /dev/null
+++ b/app-misc/fr24feed/files/fr24feed.confd
@@ -0,0 +1,5 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Pass various options to the daemon.
+FR24FEED_OPTS="--log-rotate=2 --quiet"
diff --git a/app-misc/fr24feed/files/fr24feed.ini b/app-misc/fr24feed/files/fr24feed.ini
new file mode 100644
index 000000000000..fdeb5adb6e4f
--- /dev/null
+++ b/app-misc/fr24feed/files/fr24feed.ini
@@ -0,0 +1,2 @@
+bs=yes
+raw=yes
diff --git a/app-misc/fr24feed/files/fr24feed.initd b/app-misc/fr24feed/files/fr24feed.initd
new file mode 100644
index 000000000000..a0f1b9aa6b93
--- /dev/null
+++ b/app-misc/fr24feed/files/fr24feed.initd
@@ -0,0 +1,25 @@
+#!/sbin/openrc-run
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+description="Flightradar24 data sharing software"
+name="Flightradar24 feed daemon"
+pidfile="/run/${RC_SVCNAME}.pid"
+retry="TERM/10"
+dev_shm_path="/dev/shm"
+stopsig="SIGTERM"
+
+command="/usr/bin/fr24feed"
+command_args="--monitor-file=${dev_shm_path}/${RC_SVCNAME}.txt --write-pid=${pidfile} ${FR24FEED_OPTS}"
+command_background="true"
+
+depend() {
+ use net
+}
+
+start_pre() {
+ if [ ! -d "${dev_shm_path}" ]; then
+ eerror "A mounted ${dev_shm_path} is needed in order to run fr24feed!'"
+ return 1
+ fi
+}
diff --git a/app-misc/fr24feed/fr24feed-1.0.46_p2.ebuild b/app-misc/fr24feed/fr24feed-1.0.46_p2.ebuild
new file mode 100644
index 000000000000..21cfd04ac05e
--- /dev/null
+++ b/app-misc/fr24feed/fr24feed-1.0.46_p2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="${PV/-/_}"
+MY_PV="${MY_PV/_p/-}"
+MY_P="${PN}_${MY_PV}"
+
+DESCRIPTION="Flightradar24 data sharing software"
+HOMEPAGE="https://www.flightradar24.com/share-your-data"
+SRC_URI="
+ amd64? ( https://repo-feed.flightradar24.com/linux_binaries/${MY_P}_amd64.tgz )
+ x86? ( https://repo-feed.flightradar24.com/linux_binaries/${MY_P}_i386.tgz )
+"
+S="${WORKDIR}"
+
+LICENSE="Flightradar24"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+
+RDEPEND="net-wireless/dump1090"
+
+RESTRICT="bindist mirror"
+
+QA_PREBUILT="usr/bin/fr24feed"
+
+src_install() {
+ dobin fr24feed_$(usex amd64 'amd64' 'i386')/fr24feed
+
+ insinto /etc
+ doins "${FILESDIR}"/fr24feed.ini
+
+ newinitd "${FILESDIR}"/fr24feed.initd fr24feed
+ newconfd "${FILESDIR}"/fr24feed.confd fr24feed
+}
+
+pkg_postinst() {
+ elog "Please run '/usr/bin/fr24feed --signup', to register yourself as a data feeder."
+}
diff --git a/app-misc/fr24feed/metadata.xml b/app-misc/fr24feed/metadata.xml
new file mode 100644
index 000000000000..80db19a48c4d
--- /dev/null
+++ b/app-misc/fr24feed/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <longdescription>
+ Flightradar24 operates the world's largest network of ADS-B/Mode S receivers.
+ This network, together with government air traffic control and other data sources,
+ is how Flightradar24 is able to track aircraft around the globe.
+
+ You can help us increase the flight tracking coverage in your area
+ by uploading data from your ADS-B receiver.
+
+ By sharing ADS-B data with Flightradar24, not only will you help make real-time
+ flight data available to millions of aviation enthusiasts around the world,
+ but as a thank you, you will also receive a free Flightradar24 Business Plan subscription.
+ </longdescription>
+</pkgmetadata>