summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/grabcartoons/grabcartoons-9999.ebuild')
-rw-r--r--app-misc/grabcartoons/grabcartoons-9999.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/app-misc/grabcartoons/grabcartoons-9999.ebuild b/app-misc/grabcartoons/grabcartoons-9999.ebuild
index 6a318e06fa51..b3aab0326856 100644
--- a/app-misc/grabcartoons/grabcartoons-9999.ebuild
+++ b/app-misc/grabcartoons/grabcartoons-9999.ebuild
@@ -1,14 +1,13 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
if [[ ${PV} == *9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/zzamboni/grabcartoons.git"
else
- inherit vcs-snapshot
- SRC_URI="https://github.com/zzamboni/grabcartoons/archive/cb230f01fb288a0b9f0fc437545b97d06c846bd3.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/zzamboni/grabcartoons/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
@@ -17,7 +16,6 @@ HOMEPAGE="https://zzamboni.org/code/grabcartoons/"
LICENSE="BSD"
SLOT="0"
-IUSE=""
# Opens a web page, which is unacceptable during an emerge.
RESTRICT="test"
@@ -25,9 +23,9 @@ RDEPEND="
dev-lang/perl
virtual/perl-Getopt-Long"
-PATCHES=( "${FILESDIR}"/2.8.4-fix-install-paths.patch )
+PATCHES=( "${FILESDIR}"/2.8.5-fix-install-paths.patch )
src_install() {
- emake PREFIX="${ED%/}"/usr install
+ emake PREFIX="${ED}"/usr install
einstalldocs
}