summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/hastyhex')
-rw-r--r--app-misc/hastyhex/Manifest1
-rw-r--r--app-misc/hastyhex/hastyhex-1.0.0.ebuild23
-rw-r--r--app-misc/hastyhex/metadata.xml11
3 files changed, 35 insertions, 0 deletions
diff --git a/app-misc/hastyhex/Manifest b/app-misc/hastyhex/Manifest
new file mode 100644
index 000000000000..9b755b4040ed
--- /dev/null
+++ b/app-misc/hastyhex/Manifest
@@ -0,0 +1 @@
+DIST hastyhex-1.0.0.tar.xz 4924 BLAKE2B 68b3819f8877a12eb86344b30db6aa970e36d82285e6784ccc1399e8385c1afc7b605b0ad7cac3864b473afb8bb3eb04ab56d29b90ef8604862d26c7c79b615f SHA512 e72dc7b233e37f01e553de6538506c5691f6307556fa49c67a257ec360cdf96c5a0db3802513d66fc6eedd944525cc055af72e29f2998551144577703972a71d
diff --git a/app-misc/hastyhex/hastyhex-1.0.0.ebuild b/app-misc/hastyhex/hastyhex-1.0.0.ebuild
new file mode 100644
index 000000000000..c8138ef7aacf
--- /dev/null
+++ b/app-misc/hastyhex/hastyhex-1.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A blazing fast hex dumper"
+HOMEPAGE="https://github.com/skeeto/hastyhex"
+SRC_URI="https://github.com/skeeto/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="amd64"
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -o ${PN} ${PN}.c || die
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+}
diff --git a/app-misc/hastyhex/metadata.xml b/app-misc/hastyhex/metadata.xml
new file mode 100644
index 000000000000..0e6b145389f8
--- /dev/null
+++ b/app-misc/hastyhex/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>matthew@gentoo.org</email>
+ <name>Matthew Smith</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">skeeto/hastyhex</remote-id>
+ </upstream>
+</pkgmetadata>