summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch')
-rw-r--r--app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch b/app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch
index 5ccef2047bc7..2af79a1d2967 100644
--- a/app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch
+++ b/app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch
@@ -1,5 +1,5 @@
---- hexcompare-1.0.4/Makefile
-+++ hexcompare-1.0.4/Makefile
+--- a/Makefile
++++ b/Makefile
@@ -1,9 +1,9 @@
-CFLAGS = -O3 -Wall -Wextra -pedantic -Wformat-security -std=gnu89
+CFLAGS += -Wall -Wextra -pedantic -Wformat-security -std=gnu89
@@ -8,7 +8,7 @@
hexcompare: main.c gui.c
- $(CC) $(CFLAGS) -o hexcompare main.c gui.c -lncurses
-+ $(CC) $(CFLAGS) `pkg-config --cflags ncurses` -o hexcompare main.c gui.c `pkg-config --libs ncurses`
++ $(CC) $(CFLAGS) `${PKG_CONFIG} --cflags ncurses` -o hexcompare main.c gui.c `${PKG_CONFIG} --libs ncurses`
clean:
rm -f *.o